「CentOS 7」へ「Google Chrome 76.0.3809.132」を新規インストール

ソフトウェアスイートGoogle Chrome

目次一覧

 状態:以前のversion  閲覧数:620  投稿日:2019-09-05  更新日:2019-12-20
インストール / バージョン確認 / インストール先確認

日本語フォント インストール / ヘッドレスでの動作確認


インストール / バージョン確認 / インストール先確認

 閲覧数:96 投稿日:2019-09-05 更新日:2019-09-05 

インストール


$ sudo yum install https://dl.google.com/linux/direct/google-chrome-stable_current_x86_64.rpm
読み込んだプラグイン:fastestmirror, langpacks
Repodata is over 2 weeks old. Install yum-cron? Or run: yum makecache fast
google-chrome-stable_current_x86_64.rpm                                                                                               |  57 MB  00:00:05    
/var/tmp/yum-root-O0flMz/google-chrome-stable_current_x86_64.rpm を調べています: google-chrome-stable-76.0.3809.132-1.x86_64
/var/tmp/yum-root-O0flMz/google-chrome-stable_current_x86_64.rpm をインストール済みとして設定しています
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> パッケージ google-chrome-stable.x86_64 0:76.0.3809.132-1 を インストール
--> 依存性の処理をしています: /usr/bin/lsb_release のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
base                                                                                                                                  | 3.6 kB  00:00:00    
epel/x86_64/metalink                                                                                                                  | 6.9 kB  00:00:00    
epel                                                                                                                                  | 5.3 kB  00:00:00    
extras                                                                                                                                | 3.4 kB  00:00:00    
ius                                                                                                                                   | 2.6 kB  00:00:00    
mysql-connectors-community                                                                                                            | 2.5 kB  00:00:00    
mysql-tools-community                                                                                                                 | 2.5 kB  00:00:00    
mysql57-community                                                                                                                     | 2.5 kB  00:00:00    
nginx                                                                                                                                 | 2.9 kB  00:00:00    
nux-dextop                                                                                                                            | 2.9 kB  00:00:00    
remi-safe                                                                                                                             | 3.0 kB  00:00:00    
updates                                                                                                                               | 3.4 kB  00:00:00    
(1/7): epel/x86_64/updateinfo                                                                                                         | 1.0 MB  00:00:00    
(2/7): extras/7/x86_64/primary_db                                                                                                     | 215 kB  00:00:00    
(3/7): updates/7/x86_64/primary_db                                                                                                    | 7.4 MB  00:00:00    
(4/7): epel/x86_64/primary_db                                                                                                         | 6.8 MB  00:00:01    
(5/7): nginx/primary_db                                                                                                               |  49 kB  00:00:01    
(6/7): remi-safe/primary_db                                                                                                           | 1.6 MB  00:00:02    
(7/7): nux-dextop/x86_64/primary_db                                                                                                   | 1.8 MB  00:00:04    
Determining fastest mirrors
* base: ty1.mirror.newmediaexpress.com
* epel: nrt.edge.kernel.org
* extras: ty1.mirror.newmediaexpress.com
* ius: hkg.mirror.rackspace.com
* nux-dextop: mirror.li.nux.ro
* remi-safe: ftp.riken.jp
* updates: ty1.mirror.newmediaexpress.com
--> 依存性の処理をしています: liberation-fonts のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libnss3.so(NSS_3.22)(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libssl3.so(NSS_3.28)(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libXss.so.1()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libappindicator3.so.1()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libatk-bridge-2.0.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libatspi.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libgdk-3.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> 依存性の処理をしています: libgtk-3.so.0()(64bit) のパッケージ: google-chrome-stable-76.0.3809.132-1.x86_64
--> トランザクションの確認を実行しています。
---> パッケージ at-spi2-atk.x86_64 0:2.26.2-1.el7 を インストール
--> 依存性の処理をしています: atk(x86-64) >= 2.25.2 のパッケージ: at-spi2-atk-2.26.2-1.el7.x86_64
---> パッケージ at-spi2-core.x86_64 0:2.28.0-1.el7 を インストール
---> パッケージ gtk3.x86_64 0:3.22.30-3.el7 を インストール
--> 依存性の処理をしています: libwayland-cursor(x86-64) >= 1.9.91 のパッケージ: gtk3-3.22.30-3.el7.x86_64
--> 依存性の処理をしています: libepoxy(x86-64) >= 1.0 のパッケージ: gtk3-3.22.30-3.el7.x86_64
--> 依存性の処理をしています: glib2(x86-64) >= 2.49.4 のパッケージ: gtk3-3.22.30-3.el7.x86_64
--> 依存性の処理をしています: cairo-gobject(x86-64) >= 1.14.0 のパッケージ: gtk3-3.22.30-3.el7.x86_64
--> 依存性の処理をしています: libxkbcommon.so.0(V_0.5.0)(64bit) のパッケージ: gtk3-3.22.30-3.el7.x86_64
--> 依存性の処理をしています: dconf(x86-64) のパッケージ: gtk3-3.22.30-3.el7.x86_64
--> 依存性の処理をしています: adwaita-icon-theme のパッケージ: gtk3-3.22.30-3.el7.x86_64
--> 依存性の処理をしています: libxkbcommon.so.0()(64bit) のパッケージ: gtk3-3.22.30-3.el7.x86_64
--> 依存性の処理をしています: libwayland-egl.so.1()(64bit) のパッケージ: gtk3-3.22.30-3.el7.x86_64
--> 依存性の処理をしています: libwayland-cursor.so.0()(64bit) のパッケージ: gtk3-3.22.30-3.el7.x86_64
--> 依存性の処理をしています: librest-0.7.so.0()(64bit) のパッケージ: gtk3-3.22.30-3.el7.x86_64
--> 依存性の処理をしています: libjson-glib-1.0.so.0()(64bit) のパッケージ: gtk3-3.22.30-3.el7.x86_64
--> 依存性の処理をしています: libepoxy.so.0()(64bit) のパッケージ: gtk3-3.22.30-3.el7.x86_64
--> 依存性の処理をしています: libcolord.so.2()(64bit) のパッケージ: gtk3-3.22.30-3.el7.x86_64
--> 依存性の処理をしています: libcairo-gobject.so.2()(64bit) のパッケージ: gtk3-3.22.30-3.el7.x86_64
---> パッケージ libXScrnSaver.x86_64 0:1.2.2-6.1.el7 を インストール
---> パッケージ libappindicator-gtk3.x86_64 0:12.10.0-13.el7 を インストール
--> 依存性の処理をしています: libindicator3.so.7()(64bit) のパッケージ: libappindicator-gtk3-12.10.0-13.el7.x86_64
--> 依存性の処理をしています: libdbusmenu-gtk3.so.4()(64bit) のパッケージ: libappindicator-gtk3-12.10.0-13.el7.x86_64
--> 依存性の処理をしています: libdbusmenu-glib.so.4()(64bit) のパッケージ: libappindicator-gtk3-12.10.0-13.el7.x86_64
---> パッケージ liberation-fonts.noarch 1:1.07.2-16.el7 を インストール
--> 依存性の処理をしています: liberation-serif-fonts = 1:1.07.2-16.el7 のパッケージ: 1:liberation-fonts-1.07.2-16.el7.noarch
--> 依存性の処理をしています: liberation-sans-fonts = 1:1.07.2-16.el7 のパッケージ: 1:liberation-fonts-1.07.2-16.el7.noarch
--> 依存性の処理をしています: liberation-narrow-fonts = 1:1.07.2-16.el7 のパッケージ: 1:liberation-fonts-1.07.2-16.el7.noarch
--> 依存性の処理をしています: liberation-mono-fonts = 1:1.07.2-16.el7 のパッケージ: 1:liberation-fonts-1.07.2-16.el7.noarch
---> パッケージ nss.x86_64 0:3.21.0-9.el7_2 を 更新
--> 依存性の処理をしています: nss = 3.21.0-9.el7_2 のパッケージ: nss-sysinit-3.21.0-9.el7_2.x86_64
--> 依存性の処理をしています: nss(x86-64) = 3.21.0-9.el7_2 のパッケージ: nss-tools-3.21.0-9.el7_2.x86_64
---> パッケージ nss.x86_64 0:3.36.0-7.1.el7_6 を アップデート
--> 依存性の処理をしています: nss-util >= 3.36.0-1.1 のパッケージ: nss-3.36.0-7.1.el7_6.x86_64
--> 依存性の処理をしています: nss-softokn(x86-64) >= 3.36.0-1 のパッケージ: nss-3.36.0-7.1.el7_6.x86_64
--> 依存性の処理をしています: nspr >= 4.19.0 のパッケージ: nss-3.36.0-7.1.el7_6.x86_64
--> 依存性の処理をしています: nss-pem(x86-64) のパッケージ: nss-3.36.0-7.1.el7_6.x86_64
--> 依存性の処理をしています: libnssutil3.so(NSSUTIL_3.31)(64bit) のパッケージ: nss-3.36.0-7.1.el7_6.x86_64
--> 依存性の処理をしています: libnssutil3.so(NSSUTIL_3.24)(64bit) のパッケージ: nss-3.36.0-7.1.el7_6.x86_64
---> パッケージ redhat-lsb-core.x86_64 0:4.1-27.el7.centos.1 を インストール
--> 依存性の処理をしています: redhat-lsb-submod-security(x86-64) = 4.1-27.el7.centos.1 のパッケージ: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
--> 依存性の処理をしています: spax のパッケージ: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
--> 依存性の処理をしています: /usr/sbin/fuser のパッケージ: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
--> 依存性の処理をしています: /usr/bin/lpr のパッケージ: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
--> 依存性の処理をしています: /usr/bin/lp のパッケージ: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
--> 依存性の処理をしています: /usr/bin/killall のパッケージ: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
--> トランザクションの確認を実行しています。
---> パッケージ adwaita-icon-theme.noarch 0:3.28.0-1.el7 を インストール
--> 依存性の処理をしています: adwaita-cursor-theme = 3.28.0-1.el7 のパッケージ: adwaita-icon-theme-3.28.0-1.el7.noarch
---> パッケージ atk.x86_64 0:2.22.0-3.el7 を 更新
---> パッケージ atk.x86_64 0:2.28.1-1.el7 を アップデート
---> パッケージ cairo-gobject.x86_64 0:1.15.12-3.el7 を インストール
--> 依存性の処理をしています: cairo(x86-64) = 1.15.12-3.el7 のパッケージ: cairo-gobject-1.15.12-3.el7.x86_64
---> パッケージ colord-libs.x86_64 0:1.3.4-1.el7 を インストール
--> 依存性の処理をしています: libgusb.so.2(LIBGUSB_0.1.1)(64bit) のパッケージ: colord-libs-1.3.4-1.el7.x86_64
--> 依存性の処理をしています: libgusb.so.2(LIBGUSB_0.1.0)(64bit) のパッケージ: colord-libs-1.3.4-1.el7.x86_64
--> 依存性の処理をしています: libgusb.so.2()(64bit) のパッケージ: colord-libs-1.3.4-1.el7.x86_64
---> パッケージ cups-client.x86_64 1:1.6.3-35.el7 を インストール
--> 依存性の処理をしています: cups-libs(x86-64) = 1:1.6.3-35.el7 のパッケージ: 1:cups-client-1.6.3-35.el7.x86_64
---> パッケージ dconf.x86_64 0:0.28.0-4.el7 を インストール
---> パッケージ glib2.x86_64 0:2.42.2-5.el7 を 更新
---> パッケージ glib2.x86_64 0:2.56.1-4.el7_6 を アップデート
---> パッケージ json-glib.x86_64 0:1.4.2-2.el7 を インストール
---> パッケージ libdbusmenu.x86_64 0:16.04.0-4.el7 を インストール
---> パッケージ libdbusmenu-gtk3.x86_64 0:16.04.0-4.el7 を インストール
---> パッケージ libepoxy.x86_64 0:1.5.2-1.el7 を インストール
---> パッケージ liberation-mono-fonts.noarch 1:1.07.2-16.el7 を インストール
--> 依存性の処理をしています: liberation-fonts-common = 1:1.07.2-16.el7 のパッケージ: 1:liberation-mono-fonts-1.07.2-16.el7.noarch
---> パッケージ liberation-narrow-fonts.noarch 1:1.07.2-16.el7 を インストール
---> パッケージ liberation-sans-fonts.noarch 1:1.07.2-16.el7 を インストール
---> パッケージ liberation-serif-fonts.noarch 1:1.07.2-16.el7 を インストール
---> パッケージ libindicator-gtk3.x86_64 0:12.10.1-6.el7 を インストール
---> パッケージ libwayland-cursor.x86_64 0:1.15.0-1.el7 を インストール
---> パッケージ libwayland-egl.x86_64 0:1.15.0-1.el7 を インストール
---> パッケージ libxkbcommon.x86_64 0:0.7.1-1.el7 を インストール
--> 依存性の処理をしています: xkeyboard-config のパッケージ: libxkbcommon-0.7.1-1.el7.x86_64
---> パッケージ nspr.x86_64 0:4.11.0-1.el7_2 を 更新
---> パッケージ nspr.x86_64 0:4.19.0-1.el7_5 を アップデート
---> パッケージ nss-pem.x86_64 0:1.0.3-5.el7_6.1 を インストール
---> パッケージ nss-softokn.x86_64 0:3.16.2.3-14.2.el7_2 を 更新
---> パッケージ nss-softokn.x86_64 0:3.36.0-5.el7_5 を アップデート
--> 依存性の処理をしています: nss-softokn-freebl(x86-64) >= 3.36.0-5.el7_5 のパッケージ: nss-softokn-3.36.0-5.el7_5.x86_64
---> パッケージ nss-sysinit.x86_64 0:3.21.0-9.el7_2 を 更新
---> パッケージ nss-sysinit.x86_64 0:3.36.0-7.1.el7_6 を アップデート
---> パッケージ nss-tools.x86_64 0:3.21.0-9.el7_2 を 更新
---> パッケージ nss-tools.x86_64 0:3.36.0-7.1.el7_6 を アップデート
---> パッケージ nss-util.x86_64 0:3.21.0-2.2.el7_2 を 更新
---> パッケージ nss-util.x86_64 0:3.36.0-1.1.el7_6 を アップデート
---> パッケージ psmisc.x86_64 0:22.20-15.el7 を インストール
---> パッケージ redhat-lsb-submod-security.x86_64 0:4.1-27.el7.centos.1 を インストール
---> パッケージ rest.x86_64 0:0.8.1-2.el7 を インストール
---> パッケージ spax.x86_64 0:1.5.2-13.el7 を インストール
--> トランザクションの確認を実行しています。
---> パッケージ adwaita-cursor-theme.noarch 0:3.28.0-1.el7 を インストール
---> パッケージ cairo.x86_64 0:1.14.8-2.el7 を 更新
---> パッケージ cairo.x86_64 0:1.15.12-3.el7 を アップデート
---> パッケージ cups-libs.x86_64 1:1.6.3-29.el7 を 更新
---> パッケージ cups-libs.x86_64 1:1.6.3-35.el7 を アップデート
---> パッケージ liberation-fonts-common.noarch 1:1.07.2-16.el7 を インストール
---> パッケージ libgusb.x86_64 0:0.2.9-1.el7 を インストール
---> パッケージ nss-softokn-freebl.x86_64 0:3.16.2.3-14.2.el7_2 を 更新
---> パッケージ nss-softokn-freebl.x86_64 0:3.36.0-5.el7_5 を アップデート
---> パッケージ xkeyboard-config.noarch 0:2.24-1.el7 を インストール
--> 依存性解決を終了しました。

依存性を解決しました

=============================================================================================================================================================
Package                                  アーキテクチャー     バージョン                           リポジトリー                                        容量
=============================================================================================================================================================
インストール中:
google-chrome-stable                     x86_64               76.0.3809.132-1                      /google-chrome-stable_current_x86_64               201 M
依存性関連でのインストールをします:
adwaita-cursor-theme                     noarch               3.28.0-1.el7                         base                                               641 k
adwaita-icon-theme                       noarch               3.28.0-1.el7                         base                                                11 M
at-spi2-atk                              x86_64               2.26.2-1.el7                         base                                                81 k
at-spi2-core                             x86_64               2.28.0-1.el7                         base                                               158 k
cairo-gobject                            x86_64               1.15.12-3.el7                        base                                                25 k
colord-libs                              x86_64               1.3.4-1.el7                          base                                               185 k
cups-client                              x86_64               1:1.6.3-35.el7                       base                                               151 k
dconf                                    x86_64               0.28.0-4.el7                         base                                               106 k
gtk3                                     x86_64               3.22.30-3.el7                        base                                               4.4 M
json-glib                                x86_64               1.4.2-2.el7                          base                                               134 k
libXScrnSaver                            x86_64               1.2.2-6.1.el7                        base                                                24 k
libappindicator-gtk3                     x86_64               12.10.0-13.el7                       base                                                37 k
libdbusmenu                              x86_64               16.04.0-4.el7                        base                                               132 k
libdbusmenu-gtk3                         x86_64               16.04.0-4.el7                        base                                                34 k
libepoxy                                 x86_64               1.5.2-1.el7                          base                                               211 k
liberation-fonts                         noarch               1:1.07.2-16.el7                      base                                                13 k
liberation-fonts-common                  noarch               1:1.07.2-16.el7                      base                                                27 k
liberation-mono-fonts                    noarch               1:1.07.2-16.el7                      base                                               227 k
liberation-narrow-fonts                  noarch               1:1.07.2-16.el7                      base                                               202 k
liberation-sans-fonts                    noarch               1:1.07.2-16.el7                      base                                               279 k
liberation-serif-fonts                   noarch               1:1.07.2-16.el7                      base                                               298 k
libgusb                                  x86_64               0.2.9-1.el7                          base                                                40 k
libindicator-gtk3                        x86_64               12.10.1-6.el7                        base                                                63 k
libwayland-cursor                        x86_64               1.15.0-1.el7                         base                                                20 k
libwayland-egl                           x86_64               1.15.0-1.el7                         base                                                13 k
libxkbcommon                             x86_64               0.7.1-1.el7                          base                                               108 k
nss-pem                                  x86_64               1.0.3-5.el7_6.1                      updates                                             74 k
psmisc                                   x86_64               22.20-15.el7                         base                                               141 k
redhat-lsb-core                          x86_64               4.1-27.el7.centos.1                  base                                                38 k
redhat-lsb-submod-security               x86_64               4.1-27.el7.centos.1                  base                                                15 k
rest                                     x86_64               0.8.1-2.el7                          base                                                63 k
spax                                     x86_64               1.5.2-13.el7                         base                                               260 k
xkeyboard-config                         noarch               2.24-1.el7                           base                                               834 k
依存性関連での更新をします:
atk                                      x86_64               2.28.1-1.el7                         base                                               263 k
cairo                                    x86_64               1.15.12-3.el7                        base                                               741 k
cups-libs                                x86_64               1:1.6.3-35.el7                       base                                               357 k
glib2                                    x86_64               2.56.1-4.el7_6                       updates                                            2.5 M
nspr                                     x86_64               4.19.0-1.el7_5                       base                                               127 k
nss                                      x86_64               3.36.0-7.1.el7_6                     updates                                            835 k
nss-softokn                              x86_64               3.36.0-5.el7_5                       base                                               315 k
nss-softokn-freebl                       x86_64               3.36.0-5.el7_5                       base                                               222 k
nss-sysinit                              x86_64               3.36.0-7.1.el7_6                     updates                                             62 k
nss-tools                                x86_64               3.36.0-7.1.el7_6                     updates                                            515 k
nss-util                                 x86_64               3.36.0-1.1.el7_6                     updates                                             78 k

トランザクションの要約
=============================================================================================================================================================
インストール  1 パッケージ (+33 個の依存関係のパッケージ)
更新                       ( 11 個の依存関係のパッケージ)

合計容量: 227 M
総ダウンロード容量: 26 M
Is this ok [y/d/N]:

y
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
(1/44): at-spi2-atk-2.26.2-1.el7.x86_64.rpm                                                                                           |  81 kB  00:00:00    
(2/44): adwaita-cursor-theme-3.28.0-1.el7.noarch.rpm                                                                                  | 641 kB  00:00:00    
(3/44): at-spi2-core-2.28.0-1.el7.x86_64.rpm                                                                                          | 158 kB  00:00:00    
(4/44): atk-2.28.1-1.el7.x86_64.rpm                                                                                                   | 263 kB  00:00:00    
(5/44): cairo-gobject-1.15.12-3.el7.x86_64.rpm                                                                                        |  25 kB  00:00:00    
(6/44): colord-libs-1.3.4-1.el7.x86_64.rpm                                                                                            | 185 kB  00:00:00    
(7/44): cups-client-1.6.3-35.el7.x86_64.rpm                                                                                           | 151 kB  00:00:00    
(8/44): cairo-1.15.12-3.el7.x86_64.rpm                                                                                                | 741 kB  00:00:00    
(9/44): dconf-0.28.0-4.el7.x86_64.rpm                                                                                                 | 106 kB  00:00:00    
(10/44): cups-libs-1.6.3-35.el7.x86_64.rpm                                                                                            | 357 kB  00:00:00    
(11/44): json-glib-1.4.2-2.el7.x86_64.rpm                                                                                             | 134 kB  00:00:00    
(12/44): libXScrnSaver-1.2.2-6.1.el7.x86_64.rpm                                                                                       |  24 kB  00:00:00    
(13/44): libappindicator-gtk3-12.10.0-13.el7.x86_64.rpm                                                                               |  37 kB  00:00:00    
(14/44): libdbusmenu-16.04.0-4.el7.x86_64.rpm                                                                                         | 132 kB  00:00:00    
(15/44): libdbusmenu-gtk3-16.04.0-4.el7.x86_64.rpm                                                                                    |  34 kB  00:00:00    
(16/44): libepoxy-1.5.2-1.el7.x86_64.rpm                                                                                              | 211 kB  00:00:00    
(17/44): liberation-fonts-1.07.2-16.el7.noarch.rpm                                                                                    |  13 kB  00:00:00    
(18/44): liberation-fonts-common-1.07.2-16.el7.noarch.rpm                                                                             |  27 kB  00:00:00    
(19/44): liberation-mono-fonts-1.07.2-16.el7.noarch.rpm                                                                               | 227 kB  00:00:00    
(20/44): liberation-narrow-fonts-1.07.2-16.el7.noarch.rpm                                                                             | 202 kB  00:00:00    
(21/44): liberation-sans-fonts-1.07.2-16.el7.noarch.rpm                                                                               | 279 kB  00:00:00    
(22/44): liberation-serif-fonts-1.07.2-16.el7.noarch.rpm                                                                              | 298 kB  00:00:00    
(23/44): libgusb-0.2.9-1.el7.x86_64.rpm                                                                                               |  40 kB  00:00:00    
(24/44): glib2-2.56.1-4.el7_6.x86_64.rpm                                                                                              | 2.5 MB  00:00:00    
(25/44): libindicator-gtk3-12.10.1-6.el7.x86_64.rpm                                                                                   |  63 kB  00:00:00    
(26/44): libwayland-cursor-1.15.0-1.el7.x86_64.rpm                                                                                    |  20 kB  00:00:00    
(27/44): libwayland-egl-1.15.0-1.el7.x86_64.rpm                                                                                       |  13 kB  00:00:00    
(28/44): libxkbcommon-0.7.1-1.el7.x86_64.rpm                                                                                          | 108 kB  00:00:00    
(29/44): nspr-4.19.0-1.el7_5.x86_64.rpm                                                                                               | 127 kB  00:00:00    
(30/44): gtk3-3.22.30-3.el7.x86_64.rpm                                                                                                | 4.4 MB  00:00:00    
(31/44): nss-pem-1.0.3-5.el7_6.1.x86_64.rpm                                                                                           |  74 kB  00:00:00    
(32/44): nss-softokn-3.36.0-5.el7_5.x86_64.rpm                                                                                        | 315 kB  00:00:00    
(33/44): nss-softokn-freebl-3.36.0-5.el7_5.x86_64.rpm                                                                                 | 222 kB  00:00:00    
(34/44): nss-tools-3.36.0-7.1.el7_6.x86_64.rpm                                                                                        | 515 kB  00:00:00    
(35/44): nss-3.36.0-7.1.el7_6.x86_64.rpm                                                                                              | 835 kB  00:00:00    
(36/44): redhat-lsb-core-4.1-27.el7.centos.1.x86_64.rpm                                                                               |  38 kB  00:00:00    
(37/44): nss-util-3.36.0-1.1.el7_6.x86_64.rpm                                                                                         |  78 kB  00:00:00    
(38/44): redhat-lsb-submod-security-4.1-27.el7.centos.1.x86_64.rpm                                                                    |  15 kB  00:00:00    
(39/44): rest-0.8.1-2.el7.x86_64.rpm                                                                                                  |  63 kB  00:00:00    
(40/44): nss-sysinit-3.36.0-7.1.el7_6.x86_64.rpm                                                                                      |  62 kB  00:00:00    
(41/44): psmisc-22.20-15.el7.x86_64.rpm                                                                                               | 141 kB  00:00:00    
(42/44): spax-1.5.2-13.el7.x86_64.rpm                                                                                                 | 260 kB  00:00:00    
(43/44): xkeyboard-config-2.24-1.el7.noarch.rpm                                                                                       | 834 kB  00:00:00    
(44/44): adwaita-icon-theme-3.28.0-1.el7.noarch.rpm                                                                                   |  11 MB  00:00:03    
-------------------------------------------------------------------------------------------------------------------------------------------------------------
合計                                                                                                                         8.2 MB/s |  26 MB  00:00:03    
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
 更新します              : glib2-2.56.1-4.el7_6.x86_64                                                                                                 1/56
 更新します              : nspr-4.19.0-1.el7_5.x86_64                                                                                                  2/56
 更新します              : nss-util-3.36.0-1.1.el7_6.x86_64                                                                                            3/56
 更新します              : atk-2.28.1-1.el7.x86_64                                                                                                     4/56
 更新します              : cairo-1.15.12-3.el7.x86_64                                                                                                  5/56
 インストール中          : 1:liberation-fonts-common-1.07.2-16.el7.noarch                                                                              6/56
 インストール中          : cairo-gobject-1.15.12-3.el7.x86_64                                                                                          7/56
 更新します              : 1:cups-libs-1.6.3-35.el7.x86_64                                                                                             8/56
 インストール中          : at-spi2-core-2.28.0-1.el7.x86_64                                                                                            9/56
 インストール中          : at-spi2-atk-2.26.2-1.el7.x86_64                                                                                            10/56
 インストール中          : libdbusmenu-16.04.0-4.el7.x86_64                                                                                           11/56
 インストール中          : 1:cups-client-1.6.3-35.el7.x86_64                                                                                          12/56
 インストール中          : 1:liberation-narrow-fonts-1.07.2-16.el7.noarch                                                                             13/56
 インストール中          : 1:liberation-sans-fonts-1.07.2-16.el7.noarch                                                                               14/56
 インストール中          : 1:liberation-mono-fonts-1.07.2-16.el7.noarch                                                                               15/56
 インストール中          : 1:liberation-serif-fonts-1.07.2-16.el7.noarch                                                                              16/56
 インストール中          : 1:liberation-fonts-1.07.2-16.el7.noarch                                                                                    17/56
 更新します              : nss-softokn-freebl-3.36.0-5.el7_5.x86_64                                                                                   18/56
 更新します              : nss-softokn-3.36.0-5.el7_5.x86_64                                                                                          19/56
 更新します              : nss-sysinit-3.36.0-7.1.el7_6.x86_64                                                                                        20/56
 インストール中          : nss-pem-1.0.3-5.el7_6.1.x86_64                                                                                             21/56
 更新します              : nss-3.36.0-7.1.el7_6.x86_64                                                                                                22/56
 インストール中          : redhat-lsb-submod-security-4.1-27.el7.centos.1.x86_64                                                                      23/56
 インストール中          : libgusb-0.2.9-1.el7.x86_64                                                                                                 24/56
 インストール中          : colord-libs-1.3.4-1.el7.x86_64                                                                                             25/56
 インストール中          : json-glib-1.4.2-2.el7.x86_64                                                                                               26/56
 インストール中          : rest-0.8.1-2.el7.x86_64                                                                                                    27/56
 インストール中          : dconf-0.28.0-4.el7.x86_64                                                                                                  28/56
 インストール中          : spax-1.5.2-13.el7.x86_64                                                                                                   29/56
 インストール中          : libXScrnSaver-1.2.2-6.1.el7.x86_64                                                                                         30/56
 インストール中          : libwayland-cursor-1.15.0-1.el7.x86_64                                                                                      31/56
 インストール中          : libepoxy-1.5.2-1.el7.x86_64                                                                                                32/56
 インストール中          : psmisc-22.20-15.el7.x86_64                                                                                                 33/56
 インストール中          : redhat-lsb-core-4.1-27.el7.centos.1.x86_64                                                                                 34/56
 インストール中          : xkeyboard-config-2.24-1.el7.noarch                                                                                         35/56
 インストール中          : libxkbcommon-0.7.1-1.el7.x86_64                                                                                            36/56
 インストール中          : libwayland-egl-1.15.0-1.el7.x86_64                                                                                         37/56
 インストール中          : adwaita-cursor-theme-3.28.0-1.el7.noarch                                                                                   38/56
 インストール中          : adwaita-icon-theme-3.28.0-1.el7.noarch                                                                                     39/56
 インストール中          : gtk3-3.22.30-3.el7.x86_64                                                                                                  40/56
 インストール中          : libdbusmenu-gtk3-16.04.0-4.el7.x86_64                                                                                      41/56
 インストール中          : libindicator-gtk3-12.10.1-6.el7.x86_64                                                                                     42/56
 インストール中          : libappindicator-gtk3-12.10.0-13.el7.x86_64                                                                                 43/56
 インストール中          : google-chrome-stable-76.0.3809.132-1.x86_64                                                                                44/56
Redirecting to /bin/systemctl start  atd.service
 更新します              : nss-tools-3.36.0-7.1.el7_6.x86_64                                                                                          45/56
 整理中                  : nss-tools-3.21.0-9.el7_2.x86_64                                                                                            46/56
 整理中                  : nss-sysinit-3.21.0-9.el7_2.x86_64                                                                                          47/56
 整理中                  : nss-3.21.0-9.el7_2.x86_64                                                                                                  48/56
 整理中                  : nss-softokn-3.16.2.3-14.2.el7_2.x86_64                                                                                     49/56
 整理中                  : nss-util-3.21.0-2.2.el7_2.x86_64                                                                                           50/56
 整理中                  : cairo-1.14.8-2.el7.x86_64                                                                                                  51/56
 整理中                  : atk-2.22.0-3.el7.x86_64                                                                                                    52/56
 整理中                  : glib2-2.42.2-5.el7.x86_64                                                                                                  53/56
 整理中                  : nspr-4.11.0-1.el7_2.x86_64                                                                                                 54/56
 整理中                  : nss-softokn-freebl-3.16.2.3-14.2.el7_2.x86_64                                                                              55/56
 整理中                  : 1:cups-libs-1.6.3-29.el7.x86_64                                                                                            56/56
 検証中                  : at-spi2-atk-2.26.2-1.el7.x86_64                                                                                             1/56
 検証中                  : at-spi2-core-2.28.0-1.el7.x86_64                                                                                            2/56
 検証中                  : redhat-lsb-submod-security-4.1-27.el7.centos.1.x86_64                                                                       3/56
 検証中                  : nss-tools-3.36.0-7.1.el7_6.x86_64                                                                                           4/56
 検証中                  : 1:liberation-narrow-fonts-1.07.2-16.el7.noarch                                                                              5/56
 検証中                  : libdbusmenu-gtk3-16.04.0-4.el7.x86_64                                                                                       6/56
 検証中                  : glib2-2.56.1-4.el7_6.x86_64                                                                                                 7/56
 検証中                  : adwaita-cursor-theme-3.28.0-1.el7.noarch                                                                                    8/56
 検証中                  : gtk3-3.22.30-3.el7.x86_64                                                                                                   9/56
 検証中                  : adwaita-icon-theme-3.28.0-1.el7.noarch                                                                                     10/56
 検証中                  : 1:liberation-fonts-common-1.07.2-16.el7.noarch                                                                             11/56
 検証中                  : colord-libs-1.3.4-1.el7.x86_64                                                                                             12/56
 検証中                  : libgusb-0.2.9-1.el7.x86_64                                                                                                 13/56
 検証中                  : libwayland-egl-1.15.0-1.el7.x86_64                                                                                         14/56
 検証中                  : 1:liberation-fonts-1.07.2-16.el7.noarch                                                                                    15/56
 検証中                  : nss-util-3.36.0-1.1.el7_6.x86_64                                                                                           16/56
 検証中                  : libappindicator-gtk3-12.10.0-13.el7.x86_64                                                                                 17/56
 検証中                  : libindicator-gtk3-12.10.1-6.el7.x86_64                                                                                     18/56
 検証中                  : xkeyboard-config-2.24-1.el7.noarch                                                                                         19/56
 検証中                  : google-chrome-stable-76.0.3809.132-1.x86_64                                                                                20/56
 検証中                  : nss-sysinit-3.36.0-7.1.el7_6.x86_64                                                                                        21/56
 検証中                  : nss-pem-1.0.3-5.el7_6.1.x86_64                                                                                             22/56
 検証中                  : 1:liberation-sans-fonts-1.07.2-16.el7.noarch                                                                               23/56
 検証中                  : psmisc-22.20-15.el7.x86_64                                                                                                 24/56
 検証中                  : json-glib-1.4.2-2.el7.x86_64                                                                                               25/56
 検証中                  : libdbusmenu-16.04.0-4.el7.x86_64                                                                                           26/56
 検証中                  : nss-3.36.0-7.1.el7_6.x86_64                                                                                                27/56
 検証中                  : libepoxy-1.5.2-1.el7.x86_64                                                                                                28/56
 検証中                  : rest-0.8.1-2.el7.x86_64                                                                                                    29/56
 検証中                  : dconf-0.28.0-4.el7.x86_64                                                                                                  30/56
 検証中                  : libwayland-cursor-1.15.0-1.el7.x86_64                                                                                      31/56
 検証中                  : 1:liberation-mono-fonts-1.07.2-16.el7.noarch                                                                               32/56
 検証中                  : atk-2.28.1-1.el7.x86_64                                                                                                    33/56
 検証中                  : 1:liberation-serif-fonts-1.07.2-16.el7.noarch                                                                              34/56
 検証中                  : 1:cups-client-1.6.3-35.el7.x86_64                                                                                          35/56
 検証中                  : cairo-1.15.12-3.el7.x86_64                                                                                                 36/56
 検証中                  : 1:cups-libs-1.6.3-35.el7.x86_64                                                                                            37/56
 検証中                  : nss-softokn-freebl-3.36.0-5.el7_5.x86_64                                                                                   38/56
 検証中                  : libXScrnSaver-1.2.2-6.1.el7.x86_64                                                                                         39/56
 検証中                  : nspr-4.19.0-1.el7_5.x86_64                                                                                                 40/56
 検証中                  : libxkbcommon-0.7.1-1.el7.x86_64                                                                                            41/56
 検証中                  : spax-1.5.2-13.el7.x86_64                                                                                                   42/56
 検証中                  : cairo-gobject-1.15.12-3.el7.x86_64                                                                                         43/56
 検証中                  : redhat-lsb-core-4.1-27.el7.centos.1.x86_64                                                                                 44/56
 検証中                  : nss-softokn-3.36.0-5.el7_5.x86_64                                                                                          45/56
 検証中                  : atk-2.22.0-3.el7.x86_64                                                                                                    46/56
 検証中                  : nss-softokn-freebl-3.16.2.3-14.2.el7_2.x86_64                                                                              47/56
 検証中                  : nspr-4.11.0-1.el7_2.x86_64                                                                                                 48/56
 検証中                  : nss-3.21.0-9.el7_2.x86_64                                                                                                  49/56
 検証中                  : nss-tools-3.21.0-9.el7_2.x86_64                                                                                            50/56
 検証中                  : cairo-1.14.8-2.el7.x86_64                                                                                                  51/56
 検証中                  : nss-sysinit-3.21.0-9.el7_2.x86_64                                                                                          52/56
 検証中                  : nss-util-3.21.0-2.2.el7_2.x86_64                                                                                           53/56
 検証中                  : nss-softokn-3.16.2.3-14.2.el7_2.x86_64                                                                                     54/56
 検証中                  : 1:cups-libs-1.6.3-29.el7.x86_64                                                                                            55/56
 検証中                  : glib2-2.42.2-5.el7.x86_64                                                                                                  56/56

インストール:
 google-chrome-stable.x86_64 0:76.0.3809.132-1                                                                                                              

依存性関連をインストールしました:
 adwaita-cursor-theme.noarch 0:3.28.0-1.el7       adwaita-icon-theme.noarch 0:3.28.0-1.el7         at-spi2-atk.x86_64 0:2.26.2-1.el7                        
 at-spi2-core.x86_64 0:2.28.0-1.el7               cairo-gobject.x86_64 0:1.15.12-3.el7             colord-libs.x86_64 0:1.3.4-1.el7                        
 cups-client.x86_64 1:1.6.3-35.el7                dconf.x86_64 0:0.28.0-4.el7                      gtk3.x86_64 0:3.22.30-3.el7                              
 json-glib.x86_64 0:1.4.2-2.el7                   libXScrnSaver.x86_64 0:1.2.2-6.1.el7             libappindicator-gtk3.x86_64 0:12.10.0-13.el7            
 libdbusmenu.x86_64 0:16.04.0-4.el7               libdbusmenu-gtk3.x86_64 0:16.04.0-4.el7          libepoxy.x86_64 0:1.5.2-1.el7                            
 liberation-fonts.noarch 1:1.07.2-16.el7          liberation-fonts-common.noarch 1:1.07.2-16.el7   liberation-mono-fonts.noarch 1:1.07.2-16.el7            
 liberation-narrow-fonts.noarch 1:1.07.2-16.el7   liberation-sans-fonts.noarch 1:1.07.2-16.el7     liberation-serif-fonts.noarch 1:1.07.2-16.el7            
 libgusb.x86_64 0:0.2.9-1.el7                     libindicator-gtk3.x86_64 0:12.10.1-6.el7         libwayland-cursor.x86_64 0:1.15.0-1.el7                  
 libwayland-egl.x86_64 0:1.15.0-1.el7             libxkbcommon.x86_64 0:0.7.1-1.el7                nss-pem.x86_64 0:1.0.3-5.el7_6.1                        
 psmisc.x86_64 0:22.20-15.el7                     redhat-lsb-core.x86_64 0:4.1-27.el7.centos.1     redhat-lsb-submod-security.x86_64 0:4.1-27.el7.centos.1  
 rest.x86_64 0:0.8.1-2.el7                        spax.x86_64 0:1.5.2-13.el7                       xkeyboard-config.noarch 0:2.24-1.el7                    

依存性を更新しました:
 atk.x86_64 0:2.28.1-1.el7             cairo.x86_64 0:1.15.12-3.el7        cups-libs.x86_64 1:1.6.3-35.el7     glib2.x86_64 0:2.56.1-4.el7_6            
 nspr.x86_64 0:4.19.0-1.el7_5          nss.x86_64 0:3.36.0-7.1.el7_6       nss-softokn.x86_64 0:3.36.0-5.el7_5 nss-softokn-freebl.x86_64 0:3.36.0-5.el7_5
 nss-sysinit.x86_64 0:3.36.0-7.1.el7_6 nss-tools.x86_64 0:3.36.0-7.1.el7_6 nss-util.x86_64 0:3.36.0-1.1.el7_6

完了しました!


バージョン確認


$ google-chrome --version
Google Chrome 76.0.3809.132 


インストール先確認


$ which google-chrome
/usr/bin/google-chrome


$ ls -la /usr/bin/google-chrome
lrwxrwxrwx 1 root root 31  9月  5 10:33 /usr/bin/google-chrome -> /etc/alternatives/google-chrome


日本語フォント インストール / ヘッドレスでの動作確認

 閲覧数:121 投稿日:2019-09-05 更新日:2019-09-05 

日本語フォント インストール


インストールした理由
日本語フォントがないとエラーになる場合があるため
$ sudo yum install ipa-gothic-fonts ipa-mincho-fonts ipa-pgothic-fonts ipa-pmincho-fonts
読み込んだプラグイン:fastestmirror, langpacks
google-chrome                                                                                                                         | 1.3 kB  00:00:00    
google-chrome/primary                                                                                                                 | 1.9 kB  00:00:00    
Loading mirror speeds from cached hostfile
* base: ty1.mirror.newmediaexpress.com
* epel: nrt.edge.kernel.org
* extras: ty1.mirror.newmediaexpress.com
* ius: hkg.mirror.rackspace.com
* nux-dextop: mirror.li.nux.ro
* remi-safe: ftp.riken.jp
* updates: ty1.mirror.newmediaexpress.com
google-chrome                                                                                                                                            3/3
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> パッケージ ipa-gothic-fonts.noarch 0:003.03-5.el7 を インストール
---> パッケージ ipa-mincho-fonts.noarch 0:003.03-5.el7 を インストール
---> パッケージ ipa-pgothic-fonts.noarch 0:003.03-5.el7 を インストール
---> パッケージ ipa-pmincho-fonts.noarch 0:003.03-5.el7 を インストール
--> 依存性解決を終了しました。

依存性を解決しました

=============================================================================================================================================================
Package                                     アーキテクチャー                 バージョン                                リポジトリー                    容量
=============================================================================================================================================================
インストール中:
ipa-gothic-fonts                            noarch                           003.03-5.el7                              base                           3.5 M
ipa-mincho-fonts                            noarch                           003.03-5.el7                              base                           4.8 M
ipa-pgothic-fonts                           noarch                           003.03-5.el7                              base                           3.5 M
ipa-pmincho-fonts                           noarch                           003.03-5.el7                              base                           4.9 M

トランザクションの要約
=============================================================================================================================================================
インストール  4 パッケージ

総ダウンロード容量: 17 M
インストール容量: 27 M
Is this ok [y/d/N]:

y
Downloading packages:
(1/4): ipa-pgothic-fonts-003.03-5.el7.noarch.rpm                                                                                      | 3.5 MB  00:00:01    
(2/4): ipa-gothic-fonts-003.03-5.el7.noarch.rpm                                                                                       | 3.5 MB  00:00:01    
(3/4): ipa-pmincho-fonts-003.03-5.el7.noarch.rpm                                                                                      | 4.9 MB  00:00:00    
(4/4): ipa-mincho-fonts-003.03-5.el7.noarch.rpm                                                                                       | 4.8 MB  00:00:02    
-------------------------------------------------------------------------------------------------------------------------------------------------------------
合計                                                                                                                         6.6 MB/s |  17 MB  00:00:02    
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
 インストール中          : ipa-pmincho-fonts-003.03-5.el7.noarch                                                                                        1/4
 インストール中          : ipa-gothic-fonts-003.03-5.el7.noarch                                                                                         2/4
 インストール中          : ipa-mincho-fonts-003.03-5.el7.noarch                                                                                         3/4
 インストール中          : ipa-pgothic-fonts-003.03-5.el7.noarch                                                                                        4/4
 検証中                  : ipa-pgothic-fonts-003.03-5.el7.noarch                                                                                        1/4
 検証中                  : ipa-mincho-fonts-003.03-5.el7.noarch                                                                                         2/4
 検証中                  : ipa-gothic-fonts-003.03-5.el7.noarch                                                                                         3/4
 検証中                  : ipa-pmincho-fonts-003.03-5.el7.noarch                                                                                        4/4

インストール:
 ipa-gothic-fonts.noarch 0:003.03-5.el7              ipa-mincho-fonts.noarch 0:003.03-5.el7             ipa-pgothic-fonts.noarch 0:003.03-5.el7            
 ipa-pmincho-fonts.noarch 0:003.03-5.el7            

完了しました!


ヘッドレスでの動作確認


インストールが正常に完了したので、ヘッドレスでアクセスしてみる
・ヘッドレスの場合は、オプションに"--headless"を指定する
・正しくアクセスできたか確認するため、取得HTMLをダンプするオプションの"--dump-dom"を指定する
・http://example.com/ へアクセスしてみる
$ google-chrome --headless --dump-dom http://example.com/
Fontconfig warning: "/etc/fonts/fonts.conf", line 86: unknown element "blank"
shared memfd open() failed: 無効な引数です
[0905/104503.622506:ERROR:command_buffer_proxy_impl.cc(126)] ContextResult::kTransientFailure: Failed to send GpuChannelMsg_CreateCommandBuffer.
[0905/104503.622443:WARNING:ipc_message_attachment_set.cc(49)] MessageAttachmentSet destroyed with unconsumed attachments: 0/1
[0905/104503.627670:WARNING:ipc_message_attachment_set.cc(49)] MessageAttachmentSet destroyed with unconsumed attachments: 0/1
[0905/104504.416091:ERROR:browser_process_sub_thread.cc(203)] Waited 388 ms for network service
<!DOCTYPE html>
<html><head>
   <title>Example Domain</title>

   <meta charset="utf-8">
   <meta http-equiv="Content-type" content="text/html; charset=utf-8">
   <meta name="viewport" content="width=device-width, initial-scale=1">
   <style type="text/css">
   body {
       background-color: #f0f0f2;
       margin: 0;
       padding: 0;
       font-family: "Open Sans", "Helvetica Neue", Helvetica, Arial, sans-serif;
       
   }
   div {
       width: 600px;
       margin: 5em auto;
       padding: 50px;
       background-color: #fff;
       border-radius: 1em;
   }
   a:link, a:visited {
       color: #38488f;
       text-decoration: none;
   }
   @media (max-width: 700px) {
       body {
           background-color: #fff;
       }
       div {
           width: auto;
           margin: 0 auto;
           border-radius: 0;
           padding: 1em;
       }
   }
   </style>    
</head>

<body>
<div>
   <h1>Example Domain</h1>
   <p>This domain is established to be used for illustrative examples in documents. You may use this
   domain in examples without prior coordination or asking for permission.</p>
   <p><a href="http://www.iana.org/domains/example">More information...</a></p>
</div>


</body></html>



Google Chrome・インストール・CentOS7


意図した通りスクリーンキャプチャを取得できない / unknown element "blank"エラー対応してみる / 2019/9/5における未解決な問題点

 閲覧数:110 投稿日:2019-09-05 更新日:2019-09-05 

意図した通りスクリーンキャプチャを取得できない


Chrome PHPで、意図した通りスクリーンキャプチャを取得できない(上部しか取得できない)
・コマンドで試すも、同じく意図した通り取得できないことが判明
$ google-chrome --headless --screenshot https://xxxx/article/1
Fontconfig warning: "/etc/fonts/fonts.conf", line 86: unknown element "blank"
shared memfd open() failed: 無効な引数です
[0905/114810.499237:ERROR:command_buffer_proxy_impl.cc(107)] ContextResult::kTransientFailure: Shared memory region is not valid
[0905/114813.423503:INFO:headless_shell.cc(572)] Written to file screenshot.png.
[0905/114813.463990:ERROR:browser_process_sub_thread.cc(203)] Waited 27 ms for network service


unknown element "blank"エラー対応してみる


$ less /etc/fonts/fonts.conf
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/fonts.conf file to configure system font access -->
<fontconfig>

<!--
       DO NOT EDIT THIS FILE.
       IT WILL BE REPLACED WHEN FONTCONFIG IS UPDATED.
       LOCAL CHANGES BELONG IN 'local.conf'.

       The intent of this standard configuration file is to be adequate for
       most environments.  If you have a reasonably normal environment and
       have found problems with this configuration, they are probably
       things that others will also want fixed.  Please submit any
       problems to the fontconfig bugzilla system located at fontconfig.org

       Note that the normal 'make install' procedure for fontconfig is to
       replace any existing fonts.conf file with the new version.  Place
       any local customizations in local.conf which this file references.

       Keith Packard
-->

<!-- Font directory list -->

       <dir>/usr/share/fonts</dir>
       <dir>/usr/share/X11/fonts/Type1</dir> <dir>/usr/share/X11/fonts/TTF</dir> <dir>/usr/local/share/fonts</dir>
       <dir prefix="xdg">fonts</dir>
       <!-- the following element will be removed in the future -->
       <dir>~/.fonts</dir>

<!--
 Accept deprecated 'mono' alias, replacing it with 'monospace'
-->
       <match target="pattern">
               <test qual="any" name="family">
                       <string>mono</string>
               </test>
               <edit name="family" mode="assign" binding="same">
                       <string>monospace</string>
               </edit>
       </match>

<!--
 Accept alternate 'sans serif' spelling, replacing it with 'sans-serif'
-->
       <match target="pattern">
               <test qual="any" name="family">
                       <string>sans serif</string>
               </test>
               <edit name="family" mode="assign" binding="same">
                       <string>sans-serif</string>
               </edit>
       </match>

<!--
 Accept deprecated 'sans' alias, replacing it with 'sans-serif'
-->
       <match target="pattern">
               <test qual="any" name="family">
                       <string>sans</string>
               </test>
               <edit name="family" mode="assign" binding="same">
                       <string>sans-serif</string>
               </edit>
       </match>

<!--
 Load local system customization file
-->
       <include ignore_missing="yes">/etc/fonts/conf.d</include>

<!-- Font cache directory list -->

       <cachedir>/var/cache/fontconfig</cachedir>
       <cachedir prefix="xdg">fontconfig</cachedir>
       <!-- the following element will be removed in the future -->
       <cachedir>~/.fontconfig</cachedir>

       <config>
<!--
 These are the default Unicode chars that are expected to be blank
 in fonts.  All other blank chars are assumed to be broken and
 won't appear in the resulting charsets
-->
               <blank>
                       <int>0x0020</int>       <!-- SPACE -->
                       <int>0x00A0</int>       <!-- NO-BREAK SPACE -->
                       <int>0x00AD</int>       <!-- SOFT HYPHEN -->
                       <int>0x034F</int>       <!-- COMBINING GRAPHEME JOINER -->
                       <int>0x0600</int>       <!-- ARABIC NUMBER SIGN -->
                       <int>0x0601</int>       <!-- ARABIC SIGN SANAH -->
                       <int>0x0602</int>       <!-- ARABIC FOOTNOTE MARKER -->
                       <int>0x0603</int>       <!-- ARABIC SIGN SAFHA -->
                       <int>0x06DD</int>       <!-- ARABIC END OF AYAH -->
                       <int>0x070F</int>       <!-- SYRIAC ABBREVIATION MARK -->
                       <int>0x115F</int>       <!-- HANGUL CHOSEONG FILLER -->
                       <int>0x1160</int>       <!-- HANGUL JUNGSEONG FILLER -->
                       <int>0x1680</int>       <!-- OGHAM SPACE MARK -->
                       <int>0x17B4</int>       <!-- KHMER VOWEL INHERENT AQ -->
                       <int>0x17B5</int>       <!-- KHMER VOWEL INHERENT AA -->
                       <int>0x180E</int>       <!-- MONGOLIAN VOWEL SEPARATOR -->
                       <int>0x2000</int>       <!-- EN QUAD -->
                       <int>0x2001</int>       <!-- EM QUAD -->
                       <int>0x2002</int>       <!-- EN SPACE -->
                       <int>0x2003</int>       <!-- EM SPACE -->
                       <int>0x2004</int>       <!-- THREE-PER-EM SPACE -->
                       <int>0x2005</int>       <!-- FOUR-PER-EM SPACE -->
                       <int>0x2006</int>       <!-- SIX-PER-EM SPACE -->
                       <int>0x2007</int>       <!-- FIGURE SPACE -->
                       <int>0x2008</int>       <!-- PUNCTUATION SPACE -->
                       <int>0x2009</int>       <!-- THIN SPACE -->
                       <int>0x200A</int>       <!-- HAIR SPACE -->
                       <int>0x200B</int>       <!-- ZERO WIDTH SPACE -->
                       <int>0x200C</int>       <!-- ZERO WIDTH NON-JOINER -->
                       <int>0x200D</int>       <!-- ZERO WIDTH JOINER -->
                       <int>0x200E</int>       <!-- LEFT-TO-RIGHT MARK -->
                       <int>0x200F</int>       <!-- RIGHT-TO-LEFT MARK -->
                       <int>0x2028</int>       <!-- LINE SEPARATOR -->
                       <int>0x2029</int>       <!-- PARAGRAPH SEPARATOR -->
                       <int>0x202A</int>       <!-- LEFT-TO-RIGHT EMBEDDING -->
                       <int>0x202B</int>       <!-- RIGHT-TO-LEFT EMBEDDING -->
                       <int>0x202C</int>       <!-- POP DIRECTIONAL FORMATTING -->
                       <int>0x202D</int>       <!-- LEFT-TO-RIGHT OVERRIDE -->
                       <int>0x202E</int>       <!-- RIGHT-TO-LEFT OVERRIDE -->
                       <int>0x202F</int>       <!-- NARROW NO-BREAK SPACE -->
                       <int>0x205F</int>       <!-- MEDIUM MATHEMATICAL SPACE -->
                       <int>0x2060</int>       <!-- WORD JOINER -->
                       <int>0x2061</int>       <!-- FUNCTION APPLICATION -->
                       <int>0x2062</int>       <!-- INVISIBLE TIMES -->
                       <int>0x2063</int>       <!-- INVISIBLE SEPARATOR -->
                       <int>0x206A</int>       <!-- INHIBIT SYMMETRIC SWAPPING -->
                       <int>0x206B</int>       <!-- ACTIVATE SYMMETRIC SWAPPING -->
                       <int>0x206C</int>       <!-- INHIBIT ARABIC FORM SHAPING -->
                       <int>0x206D</int>       <!-- ACTIVATE ARABIC FORM SHAPING -->
                       <int>0x206E</int>       <!-- NATIONAL DIGIT SHAPES -->
                       <int>0x206F</int>       <!-- NOMINAL DIGIT SHAPES -->
                       <int>0x2800</int>       <!-- BRAILLE PATTERN BLANK -->
                       <int>0x3000</int>       <!-- IDEOGRAPHIC SPACE -->
                       <int>0x3164</int>       <!-- HANGUL FILLER -->
                       <int>0xFEFF</int>       <!-- ZERO WIDTH NO-BREAK SPACE -->
                       <int>0xFFA0</int>       <!-- HALFWIDTH HANGUL FILLER -->
                       <int>0xFFF9</int>       <!-- INTERLINEAR ANNOTATION ANCHOR -->
                       <int>0xFFFA</int>       <!-- INTERLINEAR ANNOTATION SEPARATOR -->
                       <int>0xFFFB</int>       <!-- INTERLINEAR ANNOTATION TERMINATOR -->
               </blank>
<!--
 Rescan configuration every 30 seconds when FcFontSetList is called
-->
               <rescan>
                       <int>30</int>
               </rescan>
       </config>

</fontconfig>


$ sudo vi /etc/fonts/fonts.conf
                <!--<blank>-->
                       <int>0x0020</int>       <!-- SPACE -->

                       //中略

                       <int>0xFFFB</int>       <!-- INTERLINEAR ANNOTATION TERMINATOR -->
               <!-- </blank> -->


Amazon Linux 2 で Headless Chrome を動かしてみた

2019/9/5における未解決な問題点


(スクロール実行後の)フルスクリーンを取得できない
・スクロールはどうするの?
・サイズ指定すれば意図した通り取得できるが、サイズはURL毎に異なる

謎のエラー
shared memfd open() failed: 無効な引数です
[0905/121412.814447:ERROR:command_buffer_proxy_impl.cc(107)] ContextResult::kTransientFailure: Shared memory region is not valid
[0905/121421.608316:INFO:headless_shell.cc(572)] Written to file screenshot.png.
[0905/121422.979833:ERROR:browser_process_sub_thread.cc(203)] Waited 520 ms for network service



「CentOS 7」へインストールした「Google Chrome 76.0.3809.132」を「Google Chrome 79.0.3945.79」へアップデート  



週間人気ページランキング / 9-18 → 9-24
順位 ページタイトル抜粋 アクセス数
1 Nginx設定。エラーログレベル | Nginx(Webサーバ) 17
2 PHP実行ユーザ設定 / CentOS6 / Apache | PHP(プログラミング言語) 14
3 9回目-13.MySQL5.7.21設定 | CentOS 7 2週間無料のお試し期間 9回目(さくらVPS) 12
4 PHPのmb_send_mail関数でメール送信できない | メール処理システム 10
5 ImageMagick と imagick の違い | ImageMagick(ソフトウェアスイート) 9
6 さくらVPS0 8
6 tar: これは tar アーカイブではないようです 8
7 manページ日本語表示 | CentOS 7 (CentOS) 7
7 Reached target Shutdown メッセージが表示されたあと、シャットダウンまたは再起動プロセスがハングアップする | CentOS 7 (CentOS) 7
8 ABRT により 問題が検出されました | CentOS 7 (CentOS) 6
8 PHPファイルでchmodエラー | PHP(プログラミング言語) 6
8 「設定ファイルに、暗号化 (blowfish_secret) 用の非公開パスフレーズの設定を必要とするようになりました。」対応 6
8 Python 3.5 アンインストール / yum remove | Python(プログラミング言語) 6
9 FFmpeg 2.8.15 を yum インストール | ソフトウェアスイート 5
9 echo と cat の違い 5
10 phpMyAdmin 4.4.3(phpMyAdmin) カテゴリー 4
10 6回目-10.Nginxでバーチャルホスト設定確認 | CentOS 7 2週間無料のお試し期間 6回目(さくらVPS) 4
10 「さくらVPS」で、「CentOS6」を「CentOS7」へ変更するためには? | CentOS 7 2週間無料のお試し期間 Link(さくらVPS) 4
10 cronで定期実行しているphpファイルを、コマンドライン経由で即時実行する | cron(Linuxコマンド) 4
10 MySQL 5.5 から 5.6 へのアップグレード | MySQL(データベース) 4
2021/9/25 1:01 更新