PHP7.1 インストール失敗 / CentOS 6

プログラミング言語PHP

 状態:-  閲覧数:1,016  投稿日:2017-03-07  更新日:2019-04-30
登録リポジトリ確認
$ ls /etc/yum.repos.d/
10gen.repo             CentOS-Media.repo      city-fan.org.repo  graphviz-rhel.repo       mirrors-rpmforge-testing     remi-php70.repo  remi.repo
CentOS-Base.repo       CentOS-Vault.repo      epel-testing.repo  mirrors-rpmforge         mysql-community-source.repo  remi-php71.repo  rpmforge.repo
CentOS-Debuginfo.repo  CentOS-fasttrack.repo  epel.repo          mirrors-rpmforge-extras  mysql-community.repo         remi-safe.repo


$ sudo yum update php --enablerepo=remi-php71
読み込んだプラグイン:fastestmirror, security
更新処理の設定をしています
Loading mirror speeds from cached hostfile
* base: ftp.riken.jp
* epel: ftp.riken.jp
* extras: ftp.riken.jp
* remi-php71: mirrors.mediatemple.net
* remi-safe: mirrors.mediatemple.net
* rpmforge: ftp.riken.jp
* updates: ftp.riken.jp
remi-php71                                                                                                                            | 2.9 kB     00:00    
remi-php71/primary_db                                                                                                                 | 164 kB     00:00    
パッケージ php は利用できますが、インストールしませんでした。
更新と設定されたパッケージがありません。


失敗

 閲覧数:198 投稿日:2017-03-07 更新日:2017-03-07 
$ sudo yum install --enablerepo=remi-php71 php php-intl
読み込んだプラグイン:fastestmirror, security
インストール処理の設定をしています
Loading mirror speeds from cached hostfile
* base: ftp.riken.jp
* epel: ftp.riken.jp
* extras: ftp.riken.jp
* remi-php71: mirrors.mediatemple.net
* remi-safe: mirrors.mediatemple.net
* rpmforge: ftp.riken.jp
* updates: ftp.riken.jp
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> Package php.x86_64 0:7.1.2-1.el6.remi will be インストール
--> 依存性の処理をしています: php-common(x86-64) = 7.1.2-1.el6.remi のパッケージ: php-7.1.2-1.el6.remi.x86_64
--> 依存性の処理をしています: php-cli(x86-64) = 7.1.2-1.el6.remi のパッケージ: php-7.1.2-1.el6.remi.x86_64
---> Package php-intl.x86_64 0:5.3.3-48.el6_8 will be 更新
---> Package php-intl.x86_64 0:7.1.2-1.el6.remi will be an update
--> 依存性の処理をしています: libicuuc.so.50()(64bit) のパッケージ: php-intl-7.1.2-1.el6.remi.x86_64
--> 依存性の処理をしています: libicuio.so.50()(64bit) のパッケージ: php-intl-7.1.2-1.el6.remi.x86_64
--> 依存性の処理をしています: libicui18n.so.50()(64bit) のパッケージ: php-intl-7.1.2-1.el6.remi.x86_64
--> 依存性の処理をしています: libicudata.so.50()(64bit) のパッケージ: php-intl-7.1.2-1.el6.remi.x86_64
--> トランザクションの確認を実行しています。
---> Package libicu-last.x86_64 0:50.1.2-11.el6.remi will be インストール
---> Package php-cli.x86_64 0:5.3.3-48.el6_8 will be 更新
---> Package php-cli.x86_64 0:7.1.2-1.el6.remi will be an update
---> Package php-common.x86_64 0:5.3.3-48.el6_8 will be 更新
--> 依存性の処理をしています: php(api) = 20090626 のパッケージ: php-mcrypt-5.3.3-4.el6.x86_64
--> 依存性の処理をしています: php(zend-abi) = 20090626 のパッケージ: php-mcrypt-5.3.3-4.el6.x86_64
--> 依存性の処理をしています: php-json のパッケージ: php-tcpdf-6.2.11-1.el6.noarch
--> 依存性の処理をしています: php-json のパッケージ: phpMyAdmin-4.0.10.16-1.el6.noarch
--> 依存性の処理をしています: php-simplexml のパッケージ: phpMyAdmin-4.0.10.16-1.el6.noarch
--> 依存性の処理をしています: php-zip のパッケージ: phpMyAdmin-4.0.10.16-1.el6.noarch
--> 依存性の処理をしています: php-common(x86-64) = 5.3.3-48.el6_8 のパッケージ: php-xml-5.3.3-48.el6_8.x86_64
--> 依存性の処理をしています: php-common(x86-64) = 5.3.3-48.el6_8 のパッケージ: php-gd-5.3.3-48.el6_8.x86_64
--> 依存性の処理をしています: php-common(x86-64) = 5.3.3-48.el6_8 のパッケージ: php-process-5.3.3-48.el6_8.x86_64
--> 依存性の処理をしています: php-common(x86-64) = 5.3.3-48.el6_8 のパッケージ: php-tidy-5.3.3-48.el6_8.x86_64
--> 依存性の処理をしています: php-common(x86-64) = 5.3.3-48.el6_8 のパッケージ: php-bcmath-5.3.3-48.el6_8.x86_64
--> 依存性の処理をしています: php-common(x86-64) = 5.3.3-48.el6_8 のパッケージ: php-mbstring-5.3.3-48.el6_8.x86_64
--> 依存性の処理をしています: php-common(x86-64) = 5.3.3-48.el6_8 のパッケージ: php-pdo-5.3.3-48.el6_8.x86_64
--> 依存性の処理をしています: php-common(x86-64) = 5.3.3-48.el6_8 のパッケージ: php-mysql-5.3.3-48.el6_8.x86_64
---> Package php-common.x86_64 0:7.1.2-1.el6.remi will be an update
--> 依存性の処理をしています: php-json(x86-64) = 7.1.2-1.el6.remi のパッケージ: php-common-7.1.2-1.el6.remi.x86_64
--> トランザクションの確認を実行しています。
---> Package php-bcmath.x86_64 0:5.3.3-48.el6_8 will be 更新
---> Package php-bcmath.x86_64 0:7.1.2-1.el6.remi will be an update
---> Package php-gd.x86_64 0:5.3.3-48.el6_8 will be 更新
---> Package php-gd.x86_64 0:7.1.2-1.el6.remi will be an update
---> Package php-json.x86_64 0:7.1.2-1.el6.remi will be インストール
---> Package php-mbstring.x86_64 0:5.3.3-48.el6_8 will be 更新
---> Package php-mbstring.x86_64 0:7.1.2-1.el6.remi will be an update
---> Package php-mcrypt.x86_64 0:5.3.3-4.el6 will be 更新
---> Package php-mcrypt.x86_64 0:7.1.2-1.el6.remi will be an update
---> Package php-mysql.x86_64 0:5.3.3-48.el6_8 will be 不要
--> 依存性の処理をしています: php-mysql >= 5.2.0 のパッケージ: phpMyAdmin-4.0.10.18-1.el6.noarch
---> Package php-mysqlnd.x86_64 0:7.1.2-1.el6.remi will be obsoleting
---> Package php-pdo.x86_64 0:5.3.3-48.el6_8 will be 更新
---> Package php-pdo.x86_64 0:7.1.2-1.el6.remi will be an update
---> Package php-process.x86_64 0:5.3.3-48.el6_8 will be 更新
---> Package php-process.x86_64 0:7.1.2-1.el6.remi will be an update
---> Package php-tcpdf.noarch 0:6.2.11-1.el6 will be 更新
--> 依存性の処理をしています: php-tcpdf = 6.2.11-1.el6 のパッケージ: php-tcpdf-dejavu-sans-fonts-6.2.11-1.el6.noarch
---> Package php-tcpdf.noarch 0:6.2.13-1.el6 will be an update
--> 依存性の処理をしています: php-composer(fedora/autoloader) のパッケージ: php-tcpdf-6.2.13-1.el6.noarch
---> Package php-tidy.x86_64 0:5.3.3-48.el6_8 will be 更新
---> Package php-tidy.x86_64 0:7.1.2-1.el6.remi will be an update
---> Package php-xml.x86_64 0:5.3.3-48.el6_8 will be 更新
---> Package php-xml.x86_64 0:7.1.2-1.el6.remi will be an update
---> Package phpMyAdmin.noarch 0:4.0.10.16-1.el6 will be 更新
---> Package phpMyAdmin.noarch 0:4.0.10.18-1.el6 will be an update
--> 依存性の処理をしています: php-zip のパッケージ: phpMyAdmin-4.0.10.18-1.el6.noarch
--> トランザクションの確認を実行しています。
---> Package php-fedora-autoloader.noarch 0:0.2.1-2.el6 will be インストール
---> Package php-pecl-mysql.x86_64 0:1.0.0-0.15.20160812git230a828.el6.remi.7.1 will be インストール
---> Package php-pecl-zip.x86_64 0:1.13.5-2.el6.remi.7.1 will be インストール
---> Package php-tcpdf-dejavu-sans-fonts.noarch 0:6.2.11-1.el6 will be 更新
---> Package php-tcpdf-dejavu-sans-fonts.noarch 0:6.2.13-1.el6 will be an update
--> 依存性解決を終了しました。

依存性を解決しました

=============================================================================================================================================================
パッケージ アーキテクチャ バージョン リポジトリー 容量
=============================================================================================================================================================
インストールしています:
php x86_64 7.1.2-1.el6.remi remi-php71 2.8 M
php-mysqlnd x86_64 7.1.2-1.el6.remi remi-php71 201 k
置き換えています php-mysql.x86_64 5.3.3-48.el6_8
更新:
php-intl x86_64 7.1.2-1.el6.remi remi-php71 194 k
依存性関連でのインストールをします。:
libicu-last x86_64 50.1.2-11.el6.remi remi-safe 7.3 M
php-fedora-autoloader noarch 0.2.1-2.el6 epel 8.8 k
php-json x86_64 7.1.2-1.el6.remi remi-php71 52 k
php-pecl-mysql x86_64 1.0.0-0.15.20160812git230a828.el6.remi.7.1 remi-php71 34 k
php-pecl-zip x86_64 1.13.5-2.el6.remi.7.1 remi-php71 46 k
依存性関連での更新をします。:
php-bcmath x86_64 7.1.2-1.el6.remi remi-php71 59 k
php-cli x86_64 7.1.2-1.el6.remi remi-php71 4.1 M
php-common x86_64 7.1.2-1.el6.remi remi-php71 998 k
php-gd x86_64 7.1.2-1.el6.remi remi-php71 65 k
php-mbstring x86_64 7.1.2-1.el6.remi remi-php71 975 k
php-mcrypt x86_64 7.1.2-1.el6.remi remi-php71 49 k
php-pdo x86_64 7.1.2-1.el6.remi remi-php71 104 k
php-process x86_64 7.1.2-1.el6.remi remi-php71 60 k
php-tcpdf noarch 6.2.13-1.el6 epel 2.7 M
php-tcpdf-dejavu-sans-fonts noarch 6.2.13-1.el6 epel 315 k
php-tidy x86_64 7.1.2-1.el6.remi remi-php71 52 k
php-xml x86_64 7.1.2-1.el6.remi remi-php71 173 k
phpMyAdmin noarch 4.0.10.18-1.el6 epel 4.2 M

トランザクションの要約
=============================================================================================================================================================
インストール 7 パッケージ
アップグレード 14 パッケージ

総ダウンロード容量: 24 M
これでいいですか? [y/N]y
パッケージをダウンロードしています:
(1/21): libicu-last-50.1.2-11.el6.remi.x86_64.rpm | 7.3 MB 00:01
(2/21): php-7.1.2-1.el6.remi.x86_64.rpm | 2.8 MB 00:00
(3/21): php-bcmath-7.1.2-1.el6.remi.x86_64.rpm | 59 kB 00:00
(4/21): php-cli-7.1.2-1.el6.remi.x86_64.rpm | 4.1 MB 00:00
(5/21): php-common-7.1.2-1.el6.remi.x86_64.rpm | 998 kB 00:00
(6/21): php-fedora-autoloader-0.2.1-2.el6.noarch.rpm | 8.8 kB 00:00
(7/21): php-gd-7.1.2-1.el6.remi.x86_64.rpm | 65 kB 00:00
(8/21): php-intl-7.1.2-1.el6.remi.x86_64.rpm | 194 kB 00:00
(9/21): php-json-7.1.2-1.el6.remi.x86_64.rpm | 52 kB 00:00
(10/21): php-mbstring-7.1.2-1.el6.remi.x86_64.rpm | 975 kB 00:00
(11/21): php-mcrypt-7.1.2-1.el6.remi.x86_64.rpm | 49 kB 00:00
(12/21): php-mysqlnd-7.1.2-1.el6.remi.x86_64.rpm | 201 kB 00:00
(13/21): php-pdo-7.1.2-1.el6.remi.x86_64.rpm | 104 kB 00:00
(14/21): php-pecl-mysql-1.0.0-0.15.20160812git230a828.el6.remi.7.1.x86_64.rpm | 34 kB 00:00
(15/21): php-pecl-zip-1.13.5-2.el6.remi.7.1.x86_64.rpm | 46 kB 00:00
(16/21): php-process-7.1.2-1.el6.remi.x86_64.rpm | 60 kB 00:00
(17/21): php-tcpdf-6.2.13-1.el6.noarch.rpm | 2.7 MB 00:00
(18/21): php-tcpdf-dejavu-sans-fonts-6.2.13-1.el6.noarch.rpm | 315 kB 00:00
(19/21): php-tidy-7.1.2-1.el6.remi.x86_64.rpm | 52 kB 00:00
(20/21): php-xml-7.1.2-1.el6.remi.x86_64.rpm | 173 kB 00:00
(21/21): phpMyAdmin-4.0.10.18-1.el6.noarch.rpm | 4.2 MB 00:00
-------------------------------------------------------------------------------------------------------------------------------------------------------------
合計 3.2 MB/s | 24 MB 00:07
rpm_check_debug を実行しています
トランザクションのテストを実行しています
トランザクションのテストを成功しました
トランザクションを実行しています
更新 : php-common-7.1.2-1.el6.remi.x86_64 1/36
インストールしています : php-json-7.1.2-1.el6.remi.x86_64 2/36
更新 : php-xml-7.1.2-1.el6.remi.x86_64 3/36
更新 : php-mbstring-7.1.2-1.el6.remi.x86_64 4/36
更新 : php-gd-7.1.2-1.el6.remi.x86_64 5/36
更新 : php-cli-7.1.2-1.el6.remi.x86_64 6/36
更新 : php-process-7.1.2-1.el6.remi.x86_64 7/36
更新 : php-tidy-7.1.2-1.el6.remi.x86_64 8/36
更新 : php-pdo-7.1.2-1.el6.remi.x86_64 9/36
インストールしています : php-mysqlnd-7.1.2-1.el6.remi.x86_64 10/36
インストールしています : php-pecl-mysql-1.0.0-0.15.20160812git230a828.el6.remi.7.1.x86_64 11/36
インストールしています : php-fedora-autoloader-0.2.1-2.el6.noarch 12/36
更新 : php-mcrypt-7.1.2-1.el6.remi.x86_64 13/36
更新 : php-bcmath-7.1.2-1.el6.remi.x86_64 14/36
更新 : php-tcpdf-6.2.13-1.el6.noarch 15/36
更新 : php-tcpdf-dejavu-sans-fonts-6.2.13-1.el6.noarch 16/36
インストールしています : php-pecl-zip-1.13.5-2.el6.remi.7.1.x86_64 17/36
インストールしています : libicu-last-50.1.2-11.el6.remi.x86_64 18/36
更新 : php-intl-7.1.2-1.el6.remi.x86_64 19/36
更新 : phpMyAdmin-4.0.10.18-1.el6.noarch 20/36
Error unpacking rpm package phpMyAdmin-4.0.10.18-1.el6.noarch
error: unpacking of archive failed on file /usr/share/phpMyAdmin/doc/html: cpio: rename
インストールしています : php-7.1.2-1.el6.remi.x86_64 21/36
整理中 : php-tcpdf-dejavu-sans-fonts-6.2.11-1.el6.noarch 22/36
整理中 : php-tcpdf-6.2.11-1.el6.noarch 23/36
削除中 : php-mysql-5.3.3-48.el6_8.x86_64 24/36
整理中 : php-pdo-5.3.3-48.el6_8.x86_64 25/36
整理中 : php-cli-5.3.3-48.el6_8.x86_64 26/36
整理中 : php-bcmath-5.3.3-48.el6_8.x86_64 27/36
整理中 : php-gd-5.3.3-48.el6_8.x86_64 28/36
整理中 : php-mbstring-5.3.3-48.el6_8.x86_64 29/36
整理中 : php-process-5.3.3-48.el6_8.x86_64 30/36
整理中 : php-tidy-5.3.3-48.el6_8.x86_64 31/36
整理中 : php-xml-5.3.3-48.el6_8.x86_64 32/36
整理中 : php-mcrypt-5.3.3-4.el6.x86_64 33/36
整理中 : php-intl-5.3.3-48.el6_8.x86_64 34/36
整理中 : php-common-5.3.3-48.el6_8.x86_64 35/36
Verifying : php-xml-7.1.2-1.el6.remi.x86_64 1/36
Verifying : php-process-7.1.2-1.el6.remi.x86_64 2/36
Verifying : php-tidy-7.1.2-1.el6.remi.x86_64 3/36
Verifying : php-pdo-7.1.2-1.el6.remi.x86_64 4/36
Verifying : php-json-7.1.2-1.el6.remi.x86_64 5/36
Verifying : php-mysqlnd-7.1.2-1.el6.remi.x86_64 6/36
Verifying : php-mbstring-7.1.2-1.el6.remi.x86_64 7/36
Verifying : php-fedora-autoloader-0.2.1-2.el6.noarch 8/36
Verifying : php-7.1.2-1.el6.remi.x86_64 9/36
Verifying : php-mcrypt-7.1.2-1.el6.remi.x86_64 10/36
Verifying : libicu-last-50.1.2-11.el6.remi.x86_64 11/36
Verifying : php-bcmath-7.1.2-1.el6.remi.x86_64 12/36
Verifying : php-pecl-mysql-1.0.0-0.15.20160812git230a828.el6.remi.7.1.x86_64 13/36
Verifying : php-tcpdf-dejavu-sans-fonts-6.2.13-1.el6.noarch 14/36
Verifying : php-tcpdf-6.2.13-1.el6.noarch 15/36
Verifying : php-intl-7.1.2-1.el6.remi.x86_64 16/36
Verifying : php-gd-7.1.2-1.el6.remi.x86_64 17/36
Verifying : php-common-7.1.2-1.el6.remi.x86_64 18/36
Verifying : php-cli-7.1.2-1.el6.remi.x86_64 19/36
Verifying : php-pecl-zip-1.13.5-2.el6.remi.7.1.x86_64 20/36
Verifying : php-gd-5.3.3-48.el6_8.x86_64 21/36
Verifying : php-mcrypt-5.3.3-4.el6.x86_64 22/36
Verifying : php-cli-5.3.3-48.el6_8.x86_64 23/36
Verifying : php-bcmath-5.3.3-48.el6_8.x86_64 24/36
Verifying : php-tcpdf-dejavu-sans-fonts-6.2.11-1.el6.noarch 25/36
Verifying : php-intl-5.3.3-48.el6_8.x86_64 26/36
Verifying : php-mbstring-5.3.3-48.el6_8.x86_64 27/36
Verifying : php-process-5.3.3-48.el6_8.x86_64 28/36
phpMyAdmin-4.0.10.16-1.el6.noarch was supposed to be removed but is not!
Verifying : phpMyAdmin-4.0.10.16-1.el6.noarch 29/36
Verifying : php-pdo-5.3.3-48.el6_8.x86_64 30/36
Verifying : phpMyAdmin-4.0.10.18-1.el6.noarch 31/36
Verifying : php-xml-5.3.3-48.el6_8.x86_64 32/36
Verifying : php-tcpdf-6.2.11-1.el6.noarch 33/36
Verifying : php-common-5.3.3-48.el6_8.x86_64 34/36
Verifying : php-tidy-5.3.3-48.el6_8.x86_64 35/36
Verifying : php-mysql-5.3.3-48.el6_8.x86_64 36/36

インストール:
php.x86_64 0:7.1.2-1.el6.remi php-mysqlnd.x86_64 0:7.1.2-1.el6.remi

依存性関連をインストールしました:
libicu-last.x86_64 0:50.1.2-11.el6.remi php-fedora-autoloader.noarch 0:0.2.1-2.el6 php-json.x86_64 0:7.1.2-1.el6.remi
php-pecl-mysql.x86_64 0:1.0.0-0.15.20160812git230a828.el6.remi.7.1 php-pecl-zip.x86_64 0:1.13.5-2.el6.remi.7.1

更新:
php-intl.x86_64 0:7.1.2-1.el6.remi

依存性を更新しました:
php-bcmath.x86_64 0:7.1.2-1.el6.remi php-cli.x86_64 0:7.1.2-1.el6.remi php-common.x86_64 0:7.1.2-1.el6.remi
php-gd.x86_64 0:7.1.2-1.el6.remi php-mbstring.x86_64 0:7.1.2-1.el6.remi php-mcrypt.x86_64 0:7.1.2-1.el6.remi
php-pdo.x86_64 0:7.1.2-1.el6.remi php-process.x86_64 0:7.1.2-1.el6.remi php-tcpdf.noarch 0:6.2.13-1.el6
php-tcpdf-dejavu-sans-fonts.noarch 0:6.2.13-1.el6 php-tidy.x86_64 0:7.1.2-1.el6.remi php-xml.x86_64 0:7.1.2-1.el6.remi

置換:
php-mysql.x86_64 0:5.3.3-48.el6_8

失敗:
phpMyAdmin.noarch 0:4.0.10.16-1.el6 phpMyAdmin.noarch 0:4.0.10.18-1.el6

完了しました!


2回め

 閲覧数:165 投稿日:2017-03-07 更新日:2017-03-07 
$ sudo yum install --enablerepo=epel,remi,remi-php71 php php71-php-pear.noarch php-intl
読み込んだプラグイン:fastestmirror, security
インストール処理の設定をしています
Loading mirror speeds from cached hostfile
* base: ftp.riken.jp
* epel: ftp.riken.jp
* extras: ftp.riken.jp
* remi: mirrors.mediatemple.net
* remi-php71: mirrors.mediatemple.net
* remi-safe: mirrors.mediatemple.net
* rpmforge: ftp.riken.jp
* updates: ftp.riken.jp
remi | 2.9 kB 00:00
remi/primary_db | 1.7 MB 00:01
パッケージ php-7.1.2-1.el6.remi.x86_64 はインストール済みか最新バージョンです
パッケージ php-intl-7.1.2-1.el6.remi.x86_64 はインストール済みか最新バージョンです
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> Package php71-php-pear.noarch 1:1.10.3-1.el6.remi will be インストール
--> 依存性の処理をしています: php71-php(language) > 5.4 のパッケージ: 1:php71-php-pear-1.10.3-1.el6.remi.noarch
--> 依存性の処理をしています: php71-runtime(remi) のパッケージ: 1:php71-php-pear-1.10.3-1.el6.remi.noarch
--> 依存性の処理をしています: php71-php-zlib のパッケージ: 1:php71-php-pear-1.10.3-1.el6.remi.noarch
--> 依存性の処理をしています: php71-php-xml のパッケージ: 1:php71-php-pear-1.10.3-1.el6.remi.noarch
--> 依存性の処理をしています: php71-php-tokenizer のパッケージ: 1:php71-php-pear-1.10.3-1.el6.remi.noarch
--> 依存性の処理をしています: php71-php-posix のパッケージ: 1:php71-php-pear-1.10.3-1.el6.remi.noarch
--> 依存性の処理をしています: php71-php-pcre のパッケージ: 1:php71-php-pear-1.10.3-1.el6.remi.noarch
--> 依存性の処理をしています: php71-php-ftp のパッケージ: 1:php71-php-pear-1.10.3-1.el6.remi.noarch
--> 依存性の処理をしています: php71-php-cli のパッケージ: 1:php71-php-pear-1.10.3-1.el6.remi.noarch
--> 依存性の処理をしています: php71-php-bz2 のパッケージ: 1:php71-php-pear-1.10.3-1.el6.remi.noarch
--> トランザクションの確認を実行しています。
---> Package php71-php-cli.x86_64 0:7.1.2-1.el6.remi will be インストール
---> Package php71-php-common.x86_64 0:7.1.2-1.el6.remi will be インストール
--> 依存性の処理をしています: php71-php-json(x86-64) = 7.1.2-1.el6.remi のパッケージ: php71-php-common-7.1.2-1.el6.remi.x86_64
---> Package php71-php-process.x86_64 0:7.1.2-1.el6.remi will be インストール
---> Package php71-php-xml.x86_64 0:7.1.2-1.el6.remi will be インストール
---> Package php71-runtime.x86_64 0:1.0-1.el6.remi will be インストール
--> トランザクションの確認を実行しています。
---> Package php71-php-json.x86_64 0:7.1.2-1.el6.remi will be インストール
--> 依存性解決を終了しました。

依存性を解決しました

=============================================================================================================================================================
パッケージ アーキテクチャ バージョン リポジトリー 容量
=============================================================================================================================================================
インストールしています:
php71-php-pear noarch 1:1.10.3-1.el6.remi remi 369 k
依存性関連でのインストールをします。:
php71-php-cli x86_64 7.1.2-1.el6.remi remi 2.7 M
php71-php-common x86_64 7.1.2-1.el6.remi remi 589 k
php71-php-json x86_64 7.1.2-1.el6.remi remi 56 k
php71-php-process x86_64 7.1.2-1.el6.remi remi 60 k
php71-php-xml x86_64 7.1.2-1.el6.remi remi 149 k
php71-runtime x86_64 1.0-1.el6.remi remi 1.0 M

トランザクションの要約
=============================================================================================================================================================
インストール 7 パッケージ

総ダウンロード容量: 5.0 M
インストール済み容量: 15 M
これでいいですか? [y/N]y
パッケージをダウンロードしています:
(1/7): php71-php-cli-7.1.2-1.el6.remi.x86_64.rpm | 2.7 MB 00:01
(2/7): php71-php-common-7.1.2-1.el6.remi.x86_64.rpm | 589 kB 00:00
(3/7): php71-php-json-7.1.2-1.el6.remi.x86_64.rpm | 56 kB 00:00
(4/7): php71-php-pear-1.10.3-1.el6.remi.noarch.rpm | 369 kB 00:00
(5/7): php71-php-process-7.1.2-1.el6.remi.x86_64.rpm | 60 kB 00:00
(6/7): php71-php-xml-7.1.2-1.el6.remi.x86_64.rpm | 149 kB 00:00
(7/7): php71-runtime-1.0-1.el6.remi.x86_64.rpm | 1.0 MB 00:00
-------------------------------------------------------------------------------------------------------------------------------------------------------------
合計 1.7 MB/s | 5.0 MB 00:02
rpm_check_debug を実行しています
トランザクションのテストを実行しています
トランザクションのテストを成功しました
トランザクションを実行しています
インストールしています : php71-runtime-1.0-1.el6.remi.x86_64 1/7
インストールしています : php71-php-json-7.1.2-1.el6.remi.x86_64 2/7
インストールしています : php71-php-common-7.1.2-1.el6.remi.x86_64 3/7
インストールしています : php71-php-process-7.1.2-1.el6.remi.x86_64 4/7
インストールしています : php71-php-xml-7.1.2-1.el6.remi.x86_64 5/7
インストールしています : php71-php-cli-7.1.2-1.el6.remi.x86_64 6/7
インストールしています : 1:php71-php-pear-1.10.3-1.el6.remi.noarch 7/7
Verifying : 1:php71-php-pear-1.10.3-1.el6.remi.noarch 1/7
Verifying : php71-php-process-7.1.2-1.el6.remi.x86_64 2/7
Verifying : php71-php-common-7.1.2-1.el6.remi.x86_64 3/7
Verifying : php71-php-xml-7.1.2-1.el6.remi.x86_64 4/7
Verifying : php71-php-json-7.1.2-1.el6.remi.x86_64 5/7
Verifying : php71-runtime-1.0-1.el6.remi.x86_64 6/7
Verifying : php71-php-cli-7.1.2-1.el6.remi.x86_64 7/7

インストール:
php71-php-pear.noarch 1:1.10.3-1.el6.remi

依存性関連をインストールしました:
php71-php-cli.x86_64 0:7.1.2-1.el6.remi php71-php-common.x86_64 0:7.1.2-1.el6.remi php71-php-json.x86_64 0:7.1.2-1.el6.remi
php71-php-process.x86_64 0:7.1.2-1.el6.remi php71-php-xml.x86_64 0:7.1.2-1.el6.remi php71-runtime.x86_64 0:1.0-1.el6.remi

完了しました!


現状確認

 閲覧数:156 投稿日:2017-03-07 更新日:2017-03-07 
$ rpm -qa | grep php
php70-php-mysqlnd-7.0.14-1.el6.remi.x86_64
php70-php-gd-7.0.14-1.el6.remi.x86_64
php-json-7.1.2-1.el6.remi.x86_64
php-mysqlnd-7.1.2-1.el6.remi.x86_64
php71-php-cli-7.1.2-1.el6.remi.x86_64
php70-build-1.0-5.el6.remi.x86_64
php70-php-common-7.0.14-1.el6.remi.x86_64
php70-php-fpm-7.0.14-1.el6.remi.x86_64
php-process-7.1.2-1.el6.remi.x86_64
php-tcpdf-6.2.13-1.el6.noarch
php71-php-common-7.1.2-1.el6.remi.x86_64
php-php-gettext-1.0.11-12.el6.noarch
php70-php-devel-7.0.14-1.el6.remi.x86_64
php70-php-mcrypt-7.0.14-1.el6.remi.x86_64
php-mbstring-7.1.2-1.el6.remi.x86_64
php-fedora-autoloader-0.2.1-2.el6.noarch
php-7.1.2-1.el6.remi.x86_64
php70-1.0-5.el6.remi.x86_64
php70-php-pdo-7.0.14-1.el6.remi.x86_64
php70-php-7.0.14-1.el6.remi.x86_64
php70-php-bcmath-7.0.14-1.el6.remi.x86_64
php-common-7.1.2-1.el6.remi.x86_64
php-gd-7.1.2-1.el6.remi.x86_64
php-pdo-7.1.2-1.el6.remi.x86_64
php-mcrypt-7.1.2-1.el6.remi.x86_64
php-pecl-zip-1.13.5-2.el6.remi.7.1.x86_64
php71-runtime-1.0-1.el6.remi.x86_64
php71-php-xml-7.1.2-1.el6.remi.x86_64
php70-php-pear-1.10.1-4.el6.remi.noarch
phpMyAdmin-4.0.10.16-1.el6.noarch
php70-php-json-7.0.14-1.el6.remi.x86_64
php70-php-process-7.0.14-1.el6.remi.x86_64
php-cli-7.1.2-1.el6.remi.x86_64
php-bcmath-7.1.2-1.el6.remi.x86_64
php71-php-json-7.1.2-1.el6.remi.x86_64
php70-php-pecl-propro-2.0.1-1.el6.remi.x86_64
php70-php-pdo-dblib-7.0.14-1.el6.remi.x86_64
php70-php-mbstring-7.0.14-1.el6.remi.x86_64
php-xml-7.1.2-1.el6.remi.x86_64
php-pecl-mysql-1.0.0-0.15.20160812git230a828.el6.remi.7.1.x86_64
php-intl-7.1.2-1.el6.remi.x86_64
php71-php-pear-1.10.3-1.el6.remi.noarch
php70-php-cli-7.0.14-1.el6.remi.x86_64
php70-php-xml-7.0.14-1.el6.remi.x86_64
php-tidy-7.1.2-1.el6.remi.x86_64
php-tcpdf-dejavu-sans-fonts-6.2.13-1.el6.noarch
php71-php-process-7.1.2-1.el6.remi.x86_64
php70-runtime-1.0-5.el6.remi.x86_64
php70-php-pecl-propro-devel-2.0.1-1.el6.remi.x86_64





$ yum info php
読み込んだプラグイン:fastestmirror, security
Determining fastest mirrors
* base: ftp.iij.ad.jp
* epel: ftp.jaist.ac.jp
* extras: ftp.iij.ad.jp
* remi-safe: mirrors.mediatemple.net
* rpmforge: ftp.riken.jp
* updates: ftp.iij.ad.jp
10gen                                                                                                                                                279/279
インストール済みパッケージ
名前                : php
アーキテクチャ      : x86_64
バージョン          : 7.1.2
リリース            : 1.el6.remi
容量                : 9.2 M
リポジトリー        : installed
提供元リポジトリー  : remi-php71
要約                : PHP scripting language for creating dynamic web sites
URL                 : http://www.php.net/
ライセンス          : PHP and Zend and BSD
説明                : PHP is an HTML-embedded scripting language. PHP attempts to make it
                   : easy for developers to write dynamically generated web pages. PHP also
                   : offers built-in database integration for several commercial and
                   : non-commercial database management systems, so writing a
                   : database-enabled webpage with PHP is fairly simple. The most common
                   : use of PHP coding is probably as a replacement for CGI scripts.
                   :
                   : The php package contains the module (often referred to as mod_php)
                   : which adds support for the PHP language to Apache HTTP Server.



CentOS6環境において、PHP7.0をPHP7.1へアップグレードしたい
CentOS6のPHP7.0をPHP7.1にアップデートしてみる


phpMyAdminが正常動作しなくなる

 閲覧数:191 投稿日:2017-03-08 更新日:2017-03-08 
DBへは接続できている
どういうこと?
Warning in ./db_structure.php#16
require_once(libraries/structure.lib.php): failed to open stream: No such file or directory

Backtrace

./db_structure.php#16: require_once()

確認してみたが、libraries/structure.lib.phpファイルは存在しない
・libraries/structure.lib.php

▼/usr/share/phpMyAdmin/doc/
・昨日いろいろ試していた時刻頃に、ショートカット(シンボリックリンク?)みたいな「html;58bea4d1」が作成されているが、意味が不明
・「ls -R -la」で確認するも他で変更された箇所はないみたい
・どういうこと?

「無視する」をクリックするだけで良かった?
・とりあえず、下記処理を実行して、無視する押してリロード何回かしたら直った
・下記処理は不要かも
・意味分かっていない
$ sudo yum install --enablerepo=epel,remi,remi-php70 php70-php-pear.noarch
読み込んだプラグイン:fastestmirror, security
インストール処理の設定をしています
Loading mirror speeds from cached hostfile
epel/metalink                                                                                                                         | 6.1 kB     00:00    
* base: ftp.riken.jp
* epel: ftp.jaist.ac.jp
* extras: ftp.riken.jp
* remi: mirrors.mediatemple.net
* remi-php70: mirrors.mediatemple.net
* remi-safe: mirrors.mediatemple.net
* rpmforge: ftp.riken.jp
* updates: ftp.riken.jp
10gen                                                                                                                                 |  951 B     00:00    
base                                                                                                                                  | 3.7 kB     00:00    
epel                                                                                                                                  | 4.3 kB     00:00    
epel/primary_db                                                                                                                       | 5.9 MB     00:01    
extras                                                                                                                                | 3.4 kB     00:00    
graphviz-stable                                                                                                                       | 2.9 kB     00:00    
mysql-connectors-community                                                                                                            | 2.5 kB     00:00    
mysql-tools-community                                                                                                                 | 2.5 kB     00:00    
mysql56-community                                                                                                                     | 2.5 kB     00:00    
remi                                                                                                                                  | 2.9 kB     00:00    
remi/primary_db                                                                                                                       | 1.7 MB     00:01    
remi-php70                                                                                                                            | 2.9 kB     00:00    
remi-safe                                                                                                                             | 2.9 kB     00:00    
rpmforge                                                                                                                              | 1.9 kB     00:00    
updates                                                                                                                               | 3.4 kB     00:00    
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> Package php70-php-pear.noarch 1:1.10.1-4.el6.remi will be 更新
---> Package php70-php-pear.noarch 1:1.10.3-1.el6.remi will be an update
--> 依存性解決を終了しました。

依存性を解決しました

=============================================================================================================================================================
パッケージ                              アーキテクチャ                  バージョン                                      リポジトリー                   容量
=============================================================================================================================================================
更新:
php70-php-pear                          noarch                          1:1.10.3-1.el6.remi                             remi                          369 k

トランザクションの要約
=============================================================================================================================================================
アップグレード       1 パッケージ

総ダウンロード容量: 369 k
これでいいですか? [y/N]y
パッケージをダウンロードしています:
php70-php-pear-1.10.3-1.el6.remi.noarch.rpm                                                                                           | 369 kB     00:00    
rpm_check_debug を実行しています
トランザクションのテストを実行しています
トランザクションのテストを成功しました
トランザクションを実行しています
 更新                    : 1:php70-php-pear-1.10.3-1.el6.remi.noarch                                                                                    1/2
warning: /etc/opt/remi/php70/pear.conf created as /etc/opt/remi/php70/pear.conf.rpmnew
 整理中                  : 1:php70-php-pear-1.10.1-4.el6.remi.noarch                                                                                    2/2
 Verifying               : 1:php70-php-pear-1.10.3-1.el6.remi.noarch                                                                                    1/2
 Verifying               : 1:php70-php-pear-1.10.1-4.el6.remi.noarch                                                                                    2/2

更新:
 php70-php-pear.noarch 1:1.10.3-1.el6.remi                                                                                                                  

完了しました



・全然直ってないわ
・データベース全体やユーザアカウント、テーブルは閲覧可能だが、個別データベースは指定不可


$ cd /usr/share/phpMyAdmin/doc
$ ls -la
合計 352
drwxr-xr-x  5 root root  4096  3月  7 21:17 2017 .
drwxr-xr-x 15 root root  4096  3月  7 21:17 2017 ..
-rw-r--r--  1 1000 1000  7342  6月 23 13:31 2016 Makefile
drwxr-xr-x  2 1000 1000  4096  6月 23 13:31 2016 _ext
-rw-r--r--  1 1000 1000  9671  6月 23 13:31 2016 conf.py
-rw-r--r--  1 1000 1000 95019  6月 23 13:31 2016 config.rst
-rw-r--r--  1 1000 1000  1939  6月 23 13:31 2016 copyright.rst
-rw-r--r--  1 1000 1000 26769  6月 23 13:31 2016 credits.rst
-rw-r--r--  1 1000 1000   380  6月 23 13:31 2016 developers.rst
drwxr-xr-x  2 1000 1000  4096  6月 23 13:31 2016 doctrees
-rw-r--r--  1 1000 1000 89495  6月 23 13:31 2016 faq.rst
-rw-r--r--  1 1000 1000 12086  6月 23 13:31 2016 glossary.rst
drwxr-xr-x  4 1000 1000  4096  6月 23 13:31 2016 html
lrwxrwxrwx  1 root root    52  3月  7 21:17 2017 html;58bea4d1 -> ../../../../usr/share/doc/phpMyAdmin-4.0.10.18/html/
-rw-r--r--  1 1000 1000  1131  6月 23 13:31 2016 import_export.rst
-rw-r--r--  1 1000 1000   561  6月 23 13:31 2016 index.rst
-rw-r--r--  1 1000 1000  2652  6月 23 13:31 2016 intro.rst
-rw-r--r--  1 1000 1000  6467  6月 23 13:31 2016 make.bat
-rw-r--r--  1 1000 1000   521  6月 23 13:31 2016 other.rst
-rw-r--r--  1 1000 1000  2321  6月 23 13:31 2016 privileges.rst
-rw-r--r--  1 1000 1000  1648  6月 23 13:31 2016 require.rst
-rw-r--r--  1 1000 1000 30918  6月 23 13:31 2016 setup.rst
-rw-r--r--  1 1000 1000  6446  6月 23 13:31 2016 transformations.rst
-rw-r--r--  1 1000 1000   117  6月 23 13:31 2016 user.rst
-rw-r--r--  1 1000 1000  1208  6月 23 13:31 2016 vendors.rst



最終的に
・4.6.3のデータベース個別表示が出来なくなったため、4.6.6をインストール
phpMyAdmin-4.6.6 インストール


phpMyAdmin-4.6.6
・正常インストール出来たが、下記ファイルは存在しない
・あのエラーはどういう意味なの?
▼libraries/structure.lib.php

質問するも回答を得られなかったQ

 閲覧数:139 投稿日:2017-03-08 更新日:2017-03-08 

CentOS6環境において、PHP7.0をPHP7.1へアップグレードしたい


環境
・CentOS6

やりたいこと
・なるべく既存の環境を維持したまま、PHP7.0をPHP7.1へアップグレードしたい
・失敗した際、少なくとも現状には戻したいので…

現状リポジトリ
・とりあえず、php71リポジトリを取得してみました
・remi-php70.repo
・remi-php71.repo

yum info php
・PHP7.1

php -v
・PHP7.0
※7.1インストールしたら切り替わるかと思ったのですが、切り替わりませんでした

Q1.PHP7.0をPHP7.1へアップグレードするには?
・一旦、全てのPHPを削除するしかない?
・現状のPHP7.0を削除せず、先ずはPHP7.1へアップグレード
・7.1アップグレード確認後に、PHP7.0を削除することは出来る?

Q2.$PATHとかエクステンション関連のiniファイル設定を移行することは出来る?
・$PATHがPHP7.0に依存する形で「/remi/php70/…」に設定されているのですが、ここら辺の設定はどうなるのでしょうか?
・一旦、全てのPHPを削除すると、全てやり直しになるのでしょうか?


自分で回答してみる



もし次回試すとしたら

 閲覧数:134 投稿日:2017-03-08 更新日:2017-03-08 
yum install --enablerepo=remi-php71 php php-cli php-common php-devel php-fpm php-gd php-mbstring php-mysqlnd php-pdo php-pear php-pecl-apcu php-soap php-xml php-xmlrpc



xdebug.overload_var_dump = 0

PHP Version 7.1.2 インストール / PHP 7.0.14 からのバージョンアップ対応 / CentOS 6



週間人気ページランキング / 9-14 → 9-20
順位 ページタイトル抜粋 アクセス数
1 PHPのmb_send_mail関数でメール送信できない | メール処理システム 29
2 Nginx設定。エラーログレベル | Nginx(Webサーバ) 21
3 Python 3.5 アンインストール / yum remove | Python(プログラミング言語) 11
4 FFmpeg 2.8.15 を yum インストール | ソフトウェアスイート 10
5 PHP実行ユーザ設定 / CentOS6 / Apache | PHP(プログラミング言語) 9
6 PHP Version 7.1.2 php-mecabエクステンション対応 / PHP 7.0.14 からのアップグレード  | MeCab(形態素解析) 8
6 ソースからビルドしたPython 2.7.3 アンインストール失敗 | Python(プログラミング言語) 8
7 touch コマンド / viコマンド。新規ファイル作成時の違い | Linuxコマンド 7
7 さくらVPS0 7
8 9回目-13.MySQL5.7.21設定 | CentOS 7 2週間無料のお試し期間 9回目(さくらVPS) 6
8 「設定ファイルに、暗号化 (blowfish_secret) 用の非公開パスフレーズの設定を必要とするようになりました。」対応 6
9 PHPファイルでchmodエラー | PHP(プログラミング言語) 5
9 設定 2019/1/22 / 一般ユーザがmailコマンドでメール送信 / 管理者がmailコマンドでメール送信 5
10 Postfix | メール処理システム 4
10 CentOSでcpコマンド動作確認するためには、Control + T ではなく、 -v オプションを使用 | cp(Linuxコマンド) 4
10 499 (Request has been forbidden by antivirus) | HTTP(通信プロトコル) 4
10 tar | Linuxコマンド 4
10 Python 3.6 インストール / make altinstall | Python(プログラミング言語) 4
10 「CentOS6」から「CentOS7」への移行 | CentOS 7 (CentOS) 4
10 echo と cat の違い 4
2021/9/21 1:01 更新