ImageMagick 6.7.2.7-2.el6 を yum アンインストール / ImageMagick 6.8.8-9 を make アンインストール

ソフトウェアスイートImageMagick

目次一覧

 状態:-  閲覧数:3,208  投稿日:2016-02-14  更新日:2019-07-19
要点 / なぜアンインストールしようと思ったの?

ImageMagick 6.7.2.7-2.el6 を yum アンインストール / 問題発生

ImageMagick 6.8.8-9 を make アンインストール


要点 / なぜアンインストールしようと思ったの?

 閲覧数:365 投稿日:2016-02-14 更新日:2019-07-19 

要点


インストール方法によってアンインストール方法も異なる
・ABそれぞれのの方法でインストールした場合は、ABそれぞれのアンインストール方法を実施しなければいけない

インストール方法は2種類
A.yumでインストール
B.make install

分かり難かった点
Aのアンインストール方法が完了したのに、バージョン確認が可能
→ Bのアンインストール方法も実施

なぜアンインストールしようと思ったの?


imagickを認識できなくなる
# sudo yum install ImageMagick ImageMagick-devel ImageMagick-php
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
epel/metalink                                                                                         | 5.3 kB     00:00    
* base: ftp.nara.wide.ad.jp
* epel: ftp.jaist.ac.jp
* extras: ftp.nara.wide.ad.jp
* remi-safe: mirror.innosol.asia
* rpmforge: mirror.fairway.ne.jp
* updates: ftp.nara.wide.ad.jp
10gen                                                                                                 |  951 B     00:00    
base                                                                                                  | 3.7 kB     00:00    
extras                                                                                                | 3.4 kB     00:00    
graphviz-stable                                                                                       |  951 B     00:00    
mysql-connectors-community                                                                            | 2.5 kB     00:00    
mysql-tools-community                                                                                 | 2.5 kB     00:00    
mysql56-community                                                                                     | 2.5 kB     00:00    
remi-safe                                                                                             | 2.9 kB     00:00    
remi-safe/primary_db                                                                                  | 238 kB     00:00    
rpmforge                                                                                              | 1.9 kB     00:00    
updates                                                                                               | 3.4 kB     00:00    
Setting up Install Process
No package ImageMagick-php available.
Resolving Dependencies
--> Running transaction check
---> Package ImageMagick.x86_64 0:6.5.4.7-7.el6_5 will be updated
---> Package ImageMagick.x86_64 0:6.7.2.7-2.el6 will be an update
--> Processing Dependency: libwmf-0.2.so.7()(64bit) for package: ImageMagick-6.7.2.7-2.el6.x86_64
---> Package ImageMagick-devel.x86_64 0:6.5.4.7-7.el6_5 will be updated
---> Package ImageMagick-devel.x86_64 0:6.7.2.7-2.el6 will be an update
--> Running transaction check
---> Package libwmf.x86_64 0:0.2.8.4-25.el6_7 will be installed
--> Processing Dependency: libwmf-lite = 0.2.8.4-25.el6_7 for package: libwmf-0.2.8.4-25.el6_7.x86_64
--> Processing Dependency: gdk-pixbuf2 for package: libwmf-0.2.8.4-25.el6_7.x86_64
--> Processing Dependency: gdk-pixbuf2 for package: libwmf-0.2.8.4-25.el6_7.x86_64
--> Running transaction check
---> Package gdk-pixbuf2.x86_64 0:2.24.1-6.el6_7 will be installed
---> Package libwmf-lite.x86_64 0:0.2.8.4-22.el6.centos will be updated
---> Package libwmf-lite.x86_64 0:0.2.8.4-25.el6_7 will be an update
--> Processing Conflict: gdk-pixbuf2-2.24.1-6.el6_7.x86_64 conflicts gtk2 <= 2.21.2
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package gtk2.x86_64 0:2.20.1-4.el6 will be updated
---> Package gtk2.x86_64 0:2.24.23-6.el6 will be an update
--> Processing Dependency: glib2 >= 2.28.0-1 for package: gtk2-2.24.23-6.el6.x86_64
--> Running transaction check
---> Package glib2.x86_64 0:2.26.1-7.el6_5 will be updated
---> Package glib2.x86_64 0:2.28.8-4.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================
Package                            Arch                    Version                           Repository                Size
=============================================================================================================================
Updating:
ImageMagick                        x86_64                  6.7.2.7-2.el6                     base                     1.9 M
ImageMagick-devel                  x86_64                  6.7.2.7-2.el6                     base                      94 k
gtk2                               x86_64                  2.24.23-6.el6                     base                     3.2 M
Installing for dependencies:
gdk-pixbuf2                        x86_64                  2.24.1-6.el6_7                    updates                  501 k
libwmf                             x86_64                  0.2.8.4-25.el6_7                  updates                  132 k
Updating for dependencies:
glib2                              x86_64                  2.28.8-4.el6                      base                     1.7 M
libwmf-lite                        x86_64                  0.2.8.4-25.el6_7                  updates                   51 k

Transaction Summary
=============================================================================================================================
Install       2 Package(s)
Upgrade       5 Package(s)

Total download size: 7.5 M
Is this ok [y/N]:

y
Downloading Packages:
(1/7): ImageMagick-6.7.2.7-2.el6.x86_64.rpm                                                           | 1.9 MB     00:00    
(2/7): ImageMagick-devel-6.7.2.7-2.el6.x86_64.rpm                                                     |  94 kB     00:00    
(3/7): gdk-pixbuf2-2.24.1-6.el6_7.x86_64.rpm                                                          | 501 kB     00:00    
(4/7): glib2-2.28.8-4.el6.x86_64.rpm                                                                  | 1.7 MB     00:00    
(5/7): gtk2-2.24.23-6.el6.x86_64.rpm                                                                  | 3.2 MB     00:00    
(6/7): libwmf-0.2.8.4-25.el6_7.x86_64.rpm                                                             | 132 kB     00:00    
(7/7): libwmf-lite-0.2.8.4-25.el6_7.x86_64.rpm                                                        |  51 kB     00:00    
-----------------------------------------------------------------------------------------------------------------------------
Total                                                                                        7.3 MB/s | 7.5 MB     00:01    
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
 Updating   : glib2-2.28.8-4.el6.x86_64                                                                                1/12
 Installing : gdk-pixbuf2-2.24.1-6.el6_7.x86_64                                                                        2/12
 Updating   : libwmf-lite-0.2.8.4-25.el6_7.x86_64                                                                      3/12
 Installing : libwmf-0.2.8.4-25.el6_7.x86_64                                                                           4/12
 Updating   : ImageMagick-6.7.2.7-2.el6.x86_64                                                                         5/12
 Updating   : ImageMagick-devel-6.7.2.7-2.el6.x86_64                                                                   6/12
 Updating   : gtk2-2.24.23-6.el6.x86_64                                                                                7/12
 Cleanup    : ImageMagick-devel-6.5.4.7-7.el6_5.x86_64                                                                 8/12
 Cleanup    : ImageMagick-6.5.4.7-7.el6_5.x86_64                                                                       9/12
 Cleanup    : gtk2-2.20.1-4.el6.x86_64                                                                                10/12
 Cleanup    : glib2-2.26.1-7.el6_5.x86_64                                                                             11/12
 Cleanup    : libwmf-lite-0.2.8.4-22.el6.centos.x86_64                                                                12/12
 Verifying  : ImageMagick-devel-6.7.2.7-2.el6.x86_64                                                                   1/12
 Verifying  : ImageMagick-6.7.2.7-2.el6.x86_64                                                                         2/12
 Verifying  : glib2-2.28.8-4.el6.x86_64                                                                                3/12
 Verifying  : gdk-pixbuf2-2.24.1-6.el6_7.x86_64                                                                        4/12
 Verifying  : libwmf-0.2.8.4-25.el6_7.x86_64                                                                           5/12
 Verifying  : gtk2-2.24.23-6.el6.x86_64                                                                                6/12
 Verifying  : libwmf-lite-0.2.8.4-25.el6_7.x86_64                                                                      7/12
 Verifying  : ImageMagick-6.5.4.7-7.el6_5.x86_64                                                                       8/12
 Verifying  : libwmf-lite-0.2.8.4-22.el6.centos.x86_64                                                                 9/12
 Verifying  : gtk2-2.20.1-4.el6.x86_64                                                                                10/12
 Verifying  : ImageMagick-devel-6.5.4.7-7.el6_5.x86_64                                                                11/12
 Verifying  : glib2-2.26.1-7.el6_5.x86_64                                                                             12/12

Dependency Installed:
 gdk-pixbuf2.x86_64 0:2.24.1-6.el6_7                            libwmf.x86_64 0:0.2.8.4-25.el6_7                          

Updated:
 ImageMagick.x86_64 0:6.7.2.7-2.el6       ImageMagick-devel.x86_64 0:6.7.2.7-2.el6       gtk2.x86_64 0:2.24.23-6.el6      

Dependency Updated:
 glib2.x86_64 0:2.28.8-4.el6                              libwmf-lite.x86_64 0:0.2.8.4-25.el6_7                            

Complete!

# vi /etc/php.ini
# echo extension=imagick.so > /etc/php.d/imagick.ini
# service httpd restart
httpd を停止中:                                            [  OK  ]
httpd を起動中: Warning: DocumentRoot [  OK  ]

# rpm -ql ImageMagick
/usr/bin/animate
/usr/bin/compare
/usr/bin/composite
/usr/bin/conjure
/usr/bin/convert
/usr/bin/display
/usr/bin/identify
/usr/bin/import
/usr/bin/mogrify
/usr/bin/montage
/usr/bin/stream
/usr/lib64/ImageMagick-6.5.4
/usr/lib64/ImageMagick-6.5.4/config
/usr/lib64/ImageMagick-6.5.4/config/configure.xml

# php -i | grep imagick
# ls /etc/php.d/
bcmath.ini    exif.ini      graphviz.ini  mecab.ini           pdo_sqlite.ini  sockets.ini  tokenizer.ini  zip.ini
bz2.ini       fileinfo.ini  iconv.ini     mysqlnd.ini         phar.ini        sqlite3.ini  xml.ini
calendar.ini  ftp.ini       imagick.ini   mysqlnd_mysql.ini   posix.ini       sysvmsg.ini  xml_wddx.ini
ctype.ini     gd.ini        json.ini      mysqlnd_mysqli.ini  recode.ini      sysvsem.ini  xmlreader.ini
curl.ini      gettext.ini   mbstring.ini  pdo.ini             shmop.ini       sysvshm.ini  xmlwriter.ini
dom.ini       gmp.ini       mcrypt.ini    pdo_mysqlnd.ini     simplexml.ini   tidy.ini     xsl.ini

# pecl list | grep imagick



依存性の問題が発生


# yum install --enablerepo=remi,epel php-pecl-imagick
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
* base: ftp.nara.wide.ad.jp
* epel: ftp.jaist.ac.jp
* extras: ftp.nara.wide.ad.jp
* remi: remi.kazukioishi.net
* remi-safe: remi.kazukioishi.net
* rpmforge: mirror.fairway.ne.jp
* updates: ftp.nara.wide.ad.jp
remi                                                                                                  | 2.9 kB     00:00    
remi/primary_db                                                                                       | 1.4 MB     00:00    
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-pecl-imagick.x86_64 0:3.3.0-1.el6.remi.5.4 will be installed
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-imagick-3.3.0-1.el6.remi.5.4.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-imagick-3.3.0-1.el6.remi.5.4.x86_64
--> Processing Dependency: ImageMagick-last-libs(x86-64) >= 6.9.2 for package: php-pecl-imagick-3.3.0-1.el6.remi.5.4.x86_64
--> Processing Dependency: libMagickWand-6.Q16.so.2()(64bit) for package: php-pecl-imagick-3.3.0-1.el6.remi.5.4.x86_64
--> Processing Dependency: libMagickCore-6.Q16.so.2()(64bit) for package: php-pecl-imagick-3.3.0-1.el6.remi.5.4.x86_64
--> Running transaction check
---> Package ImageMagick-last-libs.x86_64 0:6.9.3.4-1.el6.remi will be installed
--> Processing Dependency: libwebp.so.5()(64bit) for package: ImageMagick-last-libs-6.9.3.4-1.el6.remi.x86_64
--> Processing Dependency: liblcms2.so.2()(64bit) for package: ImageMagick-last-libs-6.9.3.4-1.el6.remi.x86_64
--> Processing Dependency: libgvc.so.5()(64bit) for package: ImageMagick-last-libs-6.9.3.4-1.el6.remi.x86_64
--> Processing Dependency: libgraph.so.4()(64bit) for package: ImageMagick-last-libs-6.9.3.4-1.el6.remi.x86_64
--> Processing Dependency: libfftw3.so.3()(64bit) for package: ImageMagick-last-libs-6.9.3.4-1.el6.remi.x86_64
--> Processing Dependency: libcdt.so.4()(64bit) for package: ImageMagick-last-libs-6.9.3.4-1.el6.remi.x86_64
---> Package php-pecl-imagick.x86_64 0:3.3.0-1.el6.remi.5.4 will be installed
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-imagick-3.3.0-1.el6.remi.5.4.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-imagick-3.3.0-1.el6.remi.5.4.x86_64
--> Running transaction check
---> Package ImageMagick-last-libs.x86_64 0:6.9.3.4-1.el6.remi will be installed
--> Processing Dependency: libgvc.so.5()(64bit) for package: ImageMagick-last-libs-6.9.3.4-1.el6.remi.x86_64
--> Processing Dependency: libgraph.so.4()(64bit) for package: ImageMagick-last-libs-6.9.3.4-1.el6.remi.x86_64
--> Processing Dependency: libcdt.so.4()(64bit) for package: ImageMagick-last-libs-6.9.3.4-1.el6.remi.x86_64
---> Package fftw.x86_64 0:3.2.1-3.1.el6 will be installed
---> Package lcms2.x86_64 0:2.3-2.el6 will be installed
---> Package libwebp.x86_64 0:0.4.3-3.el6 will be installed
---> Package php-pecl-imagick.x86_64 0:3.3.0-1.el6.remi.5.4 will be installed
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-imagick-3.3.0-1.el6.remi.5.4.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-imagick-3.3.0-1.el6.remi.5.4.x86_64
--> Finished Dependency Resolution
Error: Package: ImageMagick-last-libs-6.9.3.4-1.el6.remi.x86_64 (remi)
          Requires: libgvc.so.5()(64bit)
          Available: graphviz-2.26.0-10.el6.x86_64 (base)
              libgvc.so.5()(64bit)
          Available: graphviz-2.26.3-1.el6.x86_64 (graphviz-stable)
              libgvc.so.5()(64bit)
          Installed: graphviz-2.38.0-1.el6.x86_64 (@graphviz-stable)
              Not found
          Available: graphviz-2.28.0-1.el6.x86_64 (graphviz-stable)
              Not found
          Available: graphviz-2.30.0-1.el6.x86_64 (graphviz-stable)
              Not found
          Available: graphviz-2.30.1-1.el6.x86_64 (graphviz-stable)
              Not found
          Available: graphviz-2.32.0-1.el6.x86_64 (graphviz-stable)
              Not found
          Available: graphviz-2.34.0-1.el6.x86_64 (graphviz-stable)
              Not found
          Available: graphviz-2.36.0-1.el6.x86_64 (graphviz-stable)
              Not found
Error: Package: php-pecl-imagick-3.3.0-1.el6.remi.5.4.x86_64 (remi)
          Requires: php(zend-abi) = 20100525-x86-64
          Installed: php-common-5.5.32-1.el6.remi.x86_64 (@remi-php55)
              php(zend-abi) = 20121212-64
          Available: php-common-5.3.3-40.el6_6.x86_64 (base)
              php(zend-abi) = 20090626
          Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
              php(zend-abi) = 20090626
          Available: php-common-5.3.3-46.el6_7.1.x86_64 (updates)
              php(zend-abi) = 20090626
          Available: php-common-5.4.45-2.el6.remi.x86_64 (remi)
              php(zend-abi) = 20100525-x86-64
          Available: php-common-5.4.45-3.el6.remi.x86_64 (remi)
              php(zend-abi) = 20100525-x86-64
Error: Package: ImageMagick-last-libs-6.9.3.4-1.el6.remi.x86_64 (remi)
          Requires: libcdt.so.4()(64bit)
          Available: graphviz-2.26.0-10.el6.x86_64 (base)
              libcdt.so.4()(64bit)
          Available: graphviz-2.26.3-1.el6.x86_64 (graphviz-stable)
              libcdt.so.4()(64bit)
          Installed: graphviz-2.38.0-1.el6.x86_64 (@graphviz-stable)
              Not found
          Available: graphviz-2.28.0-1.el6.x86_64 (graphviz-stable)
              Not found
          Available: graphviz-2.30.0-1.el6.x86_64 (graphviz-stable)
              Not found
          Available: graphviz-2.30.1-1.el6.x86_64 (graphviz-stable)
              Not found
          Available: graphviz-2.32.0-1.el6.x86_64 (graphviz-stable)
              Not found
          Available: graphviz-2.34.0-1.el6.x86_64 (graphviz-stable)
              Not found
          Available: graphviz-2.36.0-1.el6.x86_64 (graphviz-stable)
              Not found
Error: Package: ImageMagick-last-libs-6.9.3.4-1.el6.remi.x86_64 (remi)
          Requires: libgraph.so.4()(64bit)
          Available: graphviz-2.26.0-10.el6.x86_64 (base)
              libgraph.so.4()(64bit)
          Available: graphviz-2.26.3-1.el6.x86_64 (graphviz-stable)
              libgraph.so.4()(64bit)
          Installed: graphviz-2.38.0-1.el6.x86_64 (@graphviz-stable)
              Not found
          Available: graphviz-2.28.0-1.el6.x86_64 (graphviz-stable)
              Not found
          Available: graphviz-2.30.0-1.el6.x86_64 (graphviz-stable)
              Not found
          Available: graphviz-2.30.1-1.el6.x86_64 (graphviz-stable)
              Not found
          Available: graphviz-2.32.0-1.el6.x86_64 (graphviz-stable)
              Not found
          Available: graphviz-2.34.0-1.el6.x86_64 (graphviz-stable)
              Not found
          Available: graphviz-2.36.0-1.el6.x86_64 (graphviz-stable)
              Not found
Error: Package: php-pecl-imagick-3.3.0-1.el6.remi.5.4.x86_64 (remi)
          Requires: php(api) = 20100412-x86-64
          Installed: php-common-5.5.32-1.el6.remi.x86_64 (@remi-php55)
              php(api) = 20121113-64
          Available: php-common-5.3.3-40.el6_6.x86_64 (base)
              php(api) = 20090626
          Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
              php(api) = 20090626
          Available: php-common-5.3.3-46.el6_7.1.x86_64 (updates)
              php(api) = 20090626
          Available: php-common-5.4.45-2.el6.remi.x86_64 (remi)
              php(api) = 20100412-x86-64
          Available: php-common-5.4.45-3.el6.remi.x86_64 (remi)
              php(api) = 20100412-x86-64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


ImageMagick 6.7.2.7-2.el6 を yum アンインストール / 問題発生

 閲覧数:228 投稿日:2016-02-14 更新日:2019-07-19 

ImageMagick 6.7.2.7-2.el6 を yum アンインストール


# yum remove ImageMagick
Loaded plugins: fastestmirror, security
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package ImageMagick.x86_64 0:6.7.2.7-2.el6 will be erased
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: ImageMagick-devel-6.7.2.7-2.el6.x86_64
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: ImageMagick-devel-6.7.2.7-2.el6.x86_64
--> Processing Dependency: ImageMagick = 6.7.2.7-2.el6 for package: ImageMagick-devel-6.7.2.7-2.el6.x86_64
--> Running transaction check
---> Package ImageMagick-devel.x86_64 0:6.7.2.7-2.el6 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================
Package                             Arch                     Version                          Repository               Size
=============================================================================================================================
Removing:
ImageMagick                         x86_64                   6.7.2.7-2.el6                    @base                   7.0 M
Removing for dependencies:
ImageMagick-devel                   x86_64                   6.7.2.7-2.el6                    @base                   424 k

Transaction Summary
=============================================================================================================================
Remove        2 Package(s)

Installed size: 7.4 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
 Erasing    : ImageMagick-devel-6.7.2.7-2.el6.x86_64                                                                    1/2
 Erasing    : ImageMagick-6.7.2.7-2.el6.x86_64                                                                          2/2
 Verifying  : ImageMagick-devel-6.7.2.7-2.el6.x86_64                                                                    1/2
 Verifying  : ImageMagick-6.7.2.7-2.el6.x86_64                                                                          2/2

Removed:
 ImageMagick.x86_64 0:6.7.2.7-2.el6                                                                                        

Dependency Removed:
 ImageMagick-devel.x86_64 0:6.7.2.7-2.el6                                                                                  

Complete!


問題発生


ImageMagick を完全アンインストールしていない
# identify -version
Version: ImageMagick 6.8.8-9 Q16 x86_64 2014-03-26 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2014 ImageMagick Studio LLC
Features: DPC OpenMP
Delegates: bzlib freetype jng jpeg lcms png tiff x zlib


再度挑戦


Complete!表示されていたので、何度やっても同じだとは思うが
$ sudo yum remove ImageMagick
[sudo] password for ★★: 

Loaded plugins: fastestmirror, security
Setting up Remove Process
No Match for argument: ImageMagick
Loading mirror speeds from cached hostfile
* base: ftp.nara.wide.ad.jp
* epel: ftp.jaist.ac.jp
* extras: ftp.nara.wide.ad.jp
* remi-safe: remi.kazukioishi.net
* rpmforge: mirror.fairway.ne.jp
* updates: ftp.nara.wide.ad.jp
Package(s) ImageMagick available, but not installed.
No Packages marked for removal


状況改善せず
ImageMagick を完全アンインストールしていない
# identify -version
Version: ImageMagick 6.8.8-9 Q16 x86_64 2014-03-26 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2014 ImageMagick Studio LLC
Features: DPC OpenMP
Delegates: bzlib freetype jng jpeg lcms png tiff x zlib


ImageMagick 6.8.8-9 を make アンインストール

 閲覧数:283 投稿日:2016-02-14 更新日:2019-07-19 

/usr/local/lib/★★/



/usr/local/src/ImageMagick-6.8.8-9

/etc/ld.so.conf.d/☆☆






confファイルを削除しても効果がない


# cat /etc/ld.so.conf.d/ImageMagick.conf
/usr/local/lib

# rm /etc/ld.so.conf.d/ImageMagick.conf
rm: remove 通常ファイル `/etc/ld.so.conf.d/ImageMagick.conf'?


y
# identify -version
Version: ImageMagick 6.8.8-9 Q16 x86_64 2014-03-26 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2014 ImageMagick Studio LLC
Features: DPC OpenMP
Delegates: bzlib freetype jng jpeg lcms png tiff x zlib





指定ディレクトリ以外で実施しても効果がない


失敗例
# cd /usr/local/lib
# make uninstall
make: *** ターゲット `uninstall' を make するルールがありません.  中止.



指定ディレクトリ以外を削除しても効果がない


失敗例
# rm -rf /usr/local/lib/ImageMagick-6.8.8
# identify -version
Version: ImageMagick 6.8.8-9 Q16 x86_64 2014-03-26 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2014 ImageMagick Studio LLC
Features: DPC OpenMP
Delegates: bzlib freetype jng jpeg lcms png tiff x zlib



指定ディレクトリで実施すると削除可能


成功例
# cd /usr/local/src/ImageMagick-6.8.8-9
# make uninstall
Making uninstall in .
make[1]: ディレクトリ `/usr/local/src/ImageMagick-6.8.8-9' に入ります
( cd '/usr/local/bin' && rm -f animate compare composite conjure convert display identify import mogrify montage stream )
( cd '/usr/local/bin' && rm -f Magick-config MagickCore-config Wand-config MagickWand-config Magick++-config )
( cd '/usr/local/etc/ImageMagick-6/' && rm -f coder.xml colors.xml delegates.xml log.xml magic.xml mime.xml policy.xml quantization-table.xml thresholds.xml type.xml type-dejavu.xml type-ghostscript.xml type-windows.xml )
( cd '/usr/local/share/ImageMagick-6' && rm -f english.xml francais.xml locale.xml )
( cd '/usr/local/share/doc/ImageMagick-6' && rm -f LICENSE ChangeLog NEWS.txt )
/bin/sh ./libtool   --mode=uninstall rm -f '/usr/local/lib/libMagickCore-6.Q16.la'
libtool: uninstall: rm -f /usr/local/lib/libMagickCore-6.Q16.la /usr/local/lib/libMagickCore-6.Q16.so.2.0.0 /usr/local/lib/libMagickCore-6.Q16.so.2 /usr/local/lib/libMagickCore-6.Q16.so /usr/local/lib/libMagickCore-6.Q16.a
/bin/sh ./libtool   --mode=uninstall rm -f '/usr/local/lib/libMagickWand-6.Q16.la'
libtool: uninstall: rm -f /usr/local/lib/libMagickWand-6.Q16.la /usr/local/lib/libMagickWand-6.Q16.so.2.0.0 /usr/local/lib/libMagickWand-6.Q16.so.2 /usr/local/lib/libMagickWand-6.Q16.so /usr/local/lib/libMagickWand-6.Q16.a
/bin/sh ./libtool   --mode=uninstall rm -f '/usr/local/lib/libMagick++-6.Q16.la'
libtool: uninstall: rm -f /usr/local/lib/libMagick++-6.Q16.la /usr/local/lib/libMagick++-6.Q16.so.3.0.0 /usr/local/lib/libMagick++-6.Q16.so.3 /usr/local/lib/libMagick++-6.Q16.so /usr/local/lib/libMagick++-6.Q16.a
rm -f /usr/local/include/ImageMagick-6/magick/magick-baseconfig.h
rm -f /usr/local/share/doc/ImageMagick-6/index.html
for dir in images images/patterns www www/api www/source www/Magick++ www/api/MagickCore www/api/MagickWand ; do \
         rm -f -r /usr/local/share/doc/ImageMagick-6/$dir ; \
       done
( cd '/usr/local/include/ImageMagick-6/magick' && rm -f ImageMagick.h MagickCore.h PreRvIcccm.h accelerate.h animate.h annotate.h api.h artifact.h attribute.h blob.h cache.h cache-view.h channel.h cipher.h client.h coder.h color.h colormap.h colorspace.h compare.h composite.h compress.h configure.h constitute.h decorate.h delegate.h deprecate.h display.h distribute-cache.h distort.h draw.h effect.h enhance.h exception.h feature.h fourier.h fx.h gem.h geometry.h hashmap.h histogram.h identify.h image.h image-view.h layer.h list.h locale_.h log.h magic.h magick.h magick-config.h magick-type.h matrix.h memory_.h methods.h method-attribute.h mime.h module.h monitor.h montage.h morphology.h opencl.h option.h paint.h pixel.h pixel-accessor.h policy.h prepress.h profile.h property.h quantize.h quantum.h random_.h registry.h resample.h resize.h resource_.h segment.h semaphore.h shear.h signature.h splay-tree.h statistic.h stream.h string_.h studio.h timer.h token.h transform.h threshold.h type.h utility.h version.h widget.h xml-tree.h xwindow.h )
( cd '/usr/local/include/ImageMagick-6/magick' && rm -f magick-baseconfig.h )
( cd '/usr/local/include/ImageMagick-6/Magick++' && rm -f Blob.h CoderInfo.h Color.h Drawable.h Exception.h Functions.h Geometry.h Image.h Include.h Montage.h Pixels.h ResourceLimits.h STL.h TypeMetric.h )
( cd '/usr/local/include/ImageMagick-6' && rm -f Magick++.h )
( cd '/usr/local/share/man/man1' && rm -f Magick-config.1 MagickCore-config.1 MagickWand-config.1 Wand-config.1 Magick++-config.1 ImageMagick.1 animate.1 compare.1 composite.1 conjure.1 convert.1 display.1 identify.1 import.1 mogrify.1 montage.1 stream.1 )
( cd '/usr/local/lib/pkgconfig' && rm -f ImageMagick.pc MagickCore.pc ImageMagick-6.Q16.pc MagickCore-6.Q16.pc MagickWand.pc Wand.pc MagickWand-6.Q16.pc Wand-6.Q16.pc Magick++.pc ImageMagick++.pc Magick++-6.Q16.pc ImageMagick++-6.Q16.pc )
( cd '/usr/local/include/ImageMagick-6/wand' && rm -f MagickWand.h animate.h compare.h composite.h conjure.h convert.h deprecate.h display.h drawing-wand.h identify.h import.h magick-image.h magick-property.h magick-wand.h magick_wand.h method-attribute.h mogrify.h montage.h pixel-iterator.h pixel-wand.h stream.h wand-view.h )
make[1]: ディレクトリ `/usr/local/src/ImageMagick-6.8.8-9' から出ます

# convert -version
bash: /usr/local/bin/convert: そのようなファイルやディレクトリはありません

# identify -version
bash: /usr/local/bin/identify: そのようなファイルやディレクトリはありません



How can I remove "ImageMagick" completely?


ImageMagick × SVG変換

iMagick 3.4.0RC6 を pecl インストール



週間人気ページランキング / 9-19 → 9-25
順位 ページタイトル抜粋 アクセス数
1 Nginx設定。エラーログレベル | Nginx(Webサーバ) 16
2 PHP実行ユーザ設定 / CentOS6 / Apache | PHP(プログラミング言語) 15
3 PHPのmb_send_mail関数でメール送信できない | メール処理システム 11
4 9回目-13.MySQL5.7.21設定 | CentOS 7 2週間無料のお試し期間 9回目(さくらVPS) 10
5 tar: これは tar アーカイブではないようです 8
5 ImageMagick と imagick の違い | ImageMagick(ソフトウェアスイート) 8
5 さくらVPS0 8
6 manページ日本語表示 | CentOS 7 (CentOS) 7
6 Python 3.5 アンインストール / yum remove | Python(プログラミング言語) 7
7 ABRT により 問題が検出されました | CentOS 7 (CentOS) 6
7 Reached target Shutdown メッセージが表示されたあと、シャットダウンまたは再起動プロセスがハングアップする | CentOS 7 (CentOS) 6
7 PHPファイルでchmodエラー | PHP(プログラミング言語) 6
7 echo と cat の違い 6
8 FFmpeg 2.8.15 を yum インストール | ソフトウェアスイート 5
8 「設定ファイルに、暗号化 (blowfish_secret) 用の非公開パスフレーズの設定を必要とするようになりました。」対応 5
8 「CentOS6」から「CentOS7」への移行 | CentOS 7 (CentOS) 5
8 「さくらVPS」で、「CentOS6」を「CentOS7」へ変更するためには? | CentOS 7 2週間無料のお試し期間 Link(さくらVPS) 5
9 6回目-10.Nginxでバーチャルホスト設定確認 | CentOS 7 2週間無料のお試し期間 6回目(さくらVPS) 4
9 cronで定期実行しているphpファイルを、コマンドライン経由で即時実行する | cron(Linuxコマンド) 4
9 MySQL 5.5 から 5.6 へのアップグレード | MySQL(データベース) 4
2021/9/26 1:01 更新